SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok so I seem to be the only administrator managing a SharePoint website on behalf of the Health Service. However being as it's linked to the government someone made this website for free. I also assume that he made some of the webparts himself.

One of these web parts was an FAQ webpart which enabled you to created FAQs with a fancy format. Now however whenever I try to make an FAQ I can select it and it will now be ready to edit. Now however when I go to modify it, it will take me to an Error Page which says:

"List does not exist

The page you selected contains a list that does not exist. It may have been deleted by another user. Troubleshoot issues with Windows SharePoint Services."

Does anyone know how to find out what the webpart is looking for. What the list is called so I can make another one to replace it? Tried looking in the ".Aspx" for the page but it doesnt keep any information on the webpart. Any ideas or pointers would be very greatful.

Below is some Web Part code from the FAQ.webpart file located in the designer website.

<webParts>
  <webPart xmlns="http://schemas.microsoft.com/WebPart/v3">
    <metaData>
      <type         name="Microsoft.SharePoint.Publishing.WebControls.ContentByQueryWebPart,         Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral,         PublicKeyToken=71e9bce111e9429c" />
      <importErrorMessage>Cannot import this Web Part.</importErrorMessage>
    </metaData> <data>
      <properties>
        <property name="FilterType3" type="string" />
        <property name="PageSize" type="int">-1</property>
        <property name="SortBy" type="string">{8c06beca-0777-48f7-91c7-6da68bc07b69}</property>
        <property name="ChromeState" type="chromestate">Normal</property>
        <property name="AllowZoneChange" type="bool">True</property>
        <property name="ContentTypeBeginsWithId" type="string" />
        <property name="ServerTemplate" type="string">100</property>
        <property name="Height" type="string" />
        <property name="FilterField2" type="string" />
        <property name="SystemViewFields" type="string" />
        <property name="ParameterBindings" type="string" />
        <property name="FeedTitle" type="string" />
        <property name="AllowMinimize" type="bool">True</property>
        <property name="ContentTypeName" type="string" />
        <property name="TitleUrl" type="string" />
        <property name="AllowConnect" type="bool">True</property>
        <property name="DisplayColumns" type="int">1</property>
        <property name="XslLink" type="string" null="true" />
        <property name="ExportMode" type="exportmode">All</property>
        <property name="GroupBy" type="string" />
        <property name="DataSourcesString" type="string" />
        <property name="WebUrl" type="string">/sites/cerner</property>
        <property name="AllowHide" type="bool">True</property>
        <property name="AdditionalGroupAndSortFields" type="string" null="true" />
        <property name="FeedDescription" type="string" />
        <property name="WebsOverride" type="string" />
        <property name="CommonViewFields" type="string">Title,Text;Answer,Note;SME,Text</property>
        <property name="DisplayName" type="string" />
        <property name="ChromeType" type="chrometype">None</property>
        <property name="AdditionalFilterFields" type="string" null="true" />
        <property name="NoDefaultStyle" type="string" />
        <property name="FilterValue3" type="string" />
        <property name="BaseType" type="string" />
        <property name="FireInitialRow" type="bool">True</property>
        <property name="SortByDirection" type="Microsoft.SharePoint.Publishing.WebControls.ContentByQueryWebPart+SortDirection, Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c">Desc</property>
        <property name="DataFields" type="string" />
        <property name="GroupStyle" type="string">DefaultHeader</property>
        <property name="DataColumnRenames" type="string" />
        <property name="HeaderXslLink" type="string">/Sites/cerner/Style Library/XSL Style Sheets/FAQHeader.xsl</property>
        <property name="AllowEdit" type="bool">True</property>
        <property name="MissingAssembly" type="string">Cannot import this Web Part.</property>
        <property name="HelpUrl" type="string" />
        <property name="ViewFieldsOverride" type="string" />
        <property name="FilterField1" type="string" />
        <property name="UseCache" type="bool">True</property>
        <property name="ShowUntargetedItems" type="bool">False</property>
        <property name="HelpMode" type="helpmode">Modeless</property>
        <property name="DataSourceID" type="string" />
        <property name="ListName" type="string">FAQ</property>
        <property name="FilterType1" type="string" />
        <property name="Default" type="string" />
        <property name="FilterType2" type="string" />
        <property name="FilterOperator1" type="Microsoft.SharePoint.Publishing.WebControls.ContentByQueryWebPart+FilterFieldQueryOperator, Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c">Eq</property>
        <property name="ViewFlag" type="string" />
        <property name="FilterOperator3" type="Microsoft.SharePoint.Publishing.WebControls.ContentByQueryWebPart+FilterFieldQueryOperator, Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c">Eq</property>
        <property name="FilterOperator2" type="Microsoft.SharePoint.Publishing.WebControls.ContentByQueryWebPart+FilterFieldQueryOperator, Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c">Eq</property>
        <property name="GroupByFieldType" type="string" />
        <property name="UseCopyUtil" type="bool">True</property>
        <property name="Description" type="string">Use to display a dynamic view of content from your site on a web page</property>
        <property name="Filter1ChainingOperator" type="Microsoft.SharePoint.Publishing.WebControls.ContentByQueryWebPart+FilterChainingOperator, Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c">Or</property>
        <property name="ItemLimit" type="int">15</property>
        <property name="SortByFieldType" type="string">DateTime</property>
        <property name="ListGuid" type="string">A72FB448-BAC3-4661-BEAB-F435E441AA1D</property>
        <property name="ViewContentTypeId" type="string" />
        <property name="ItemXslLink" type="string">/Sites/cerner/Style Library/XSL Style Sheets/FAQItemStyle.xsl</property>
        <property name="FeedEnabled" type="bool">False</property>
        <property name="MainXslLink" type="string">/Sites/cerner/Style Library/XSL Style Sheets/NHSContentQueryMain.xsl</property>
        <property name="TitleIconImageUrl" type="string" />
        <property name="Filter2ChainingOperator" type="Microsoft.SharePoint.Publishing.WebControls.ContentByQueryWebPart+FilterChainingOperator, Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c">Or</property>
        <property name="FilterValue1" type="string" />
        <property name="ListsOverride" type="string" />
        <property name="GroupByDirection" type="Microsoft.SharePoint.Publishing.WebControls.ContentByQueryWebPart+SortDirection, Microsoft.SharePoint.Publishing, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c">Desc</property>
        <property name="Direction" type="direction">NotSet</property>
        <property name="QueryOverride" type="string" />
        <property name="UseSQLDataSourcePaging" type="bool">True</property>
        <property name="Width" type="string" />
        <property name="FilterByAudience" type="bool">False</property>
        <property name="FilterValue2" type="string" />
        <property name="SampleData" type="string">&lt;dsQueryResponse&gt;                 &lt;Rows&gt;                     &lt;Row Title="Item 1" LinkUrl="http://Item1" Group="Group Header" __begincolumn="True" __begingroup="True" /&gt;                     &lt;Row Title="Item 2" LinkUrl="http://Item2" __begincolumn="False" __begingroup="False" /&gt;                     &lt;Row Title="Item 3" LinkUrl="http://Item3" __begincolumn="False" __begingroup="False" /&gt;                 &lt;/Rows&gt;                 &lt;/dsQueryResponse&gt;</property>
        <property name="Xsl" type="string">&lt;xsl:stylesheet xmlns:x="http://www.w3.org/2001/XMLSchema" version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:cmswrt="http://schemas.microsoft.com/WebPart/v3/Publishing/runtime" exclude-result-prefixes="xsl cmswrt x" &gt; &lt;xsl:import href="/Style Library/XSL Style Sheets/Header.xsl" /&gt; &lt;xsl:import href="/Style Library/XSL Style Sheets/ItemStyle.xsl" /&gt; &lt;xsl:import href="/Style Library/XSL Style Sheets/ContentQueryMain.xsl" /&gt; &lt;/xsl:stylesheet&gt;</property>
        <property name="CacheXslStorage" type="bool">True</property>
        <property name="Hidden" type="bool">False</property>
        <property name="Title" type="string">FAQ Content Web Part</property>
        <property name="ShowWithSampleData" type="bool">False</property>
        <property name="CacheXslTimeOut" type="int">86400</property>
        <property name="ItemStyle" type="string">NoImage</property>
        <property name="AllowClose" type="bool">True</property>
        <property name="FilterField3" type="string" />
        <property name="CatalogIconImageUrl" type="string"></property>
      </properties>
    </data>

Thanks for looking.

share|improve this question
    
Please share the ULS logs ..It will help us narrow down the cause. – Arko D Jun 25 '12 at 10:57

There could be seevral reasons for this:

  • Please go to the list, check the permission settings, make sure you have permission to the list.
  • Can you access the list directly using the URL?
  • You can find the list using the list GUID, type the this URL in browser: http://yourserver/_layouts/listedit.aspx?List={ceb31d57-dea6-4524-ba47-bf15f6f73d4a}, it will go to the list settings page and you can check the list settings.
share|improve this answer

By looking at the markup, It is content query webpart. It is looking for a list with GUID set in below property.

<property name="ListGuid" type="string">A72FB448-BAC3-4661-BEAB-F435E441AA1D</property>

The list should be under site with URL set in below property:

<property name="WebUrl" type="string">/sites/cerner</property>

Better, you create a new list in that site and update the GUID.

To find column names, Open the xsl in sharepoint designer or notepad from the path in below property and look for all <xsl:value-of select="{column names}" /> :

<property name="ItemXslLink" type="string">/Sites/cerner/Style Library/XSL Style Sheets/FAQItemStyle.xsl</property>
share|improve this answer

Here is something to try quickly, that worked to resolve my problem. It took me many hours to find a fix for this problem. No single article covered all the hoops I had to jump through to resolve this. It was not an obvious fix. It will only cost you a couple minutes of your time to try and if you take screenshots before making the change, it will be easy to revert your selections and there are no major repercussions.

1) Login to your SharePoint 2013 page any way possible where you can eventually get to the Site Settings of the site where your page is giving you the "List does not exist" error.

You may have to log in to a subsite and then work your way up to the Top Level Site or vice versa; login to Top Level and go to Site Contents where you will see links to your subsites at the bottom.

2) Click on the gear icon at the top right of the page and select Site Settings.

3) Under Look and Feel select Master Page and change the current master page selections to one of the defaults, like seattle or oslo.

4) Click OK to save.

5) Refresh your page that's getting the "List does not exist" error.

If it worked, you're blessed! If not, I guess you'll just have to keep digging until the lightbulb turns on.

Hopefully this helps someone who just wants a simple answer instead of the numerous iterations it took me to get this figured out. This solution is nowhere else that I have found. I did go through all the other suggestions in this site and more.

If anyone is interested I can explain why this happened.

I'm using IE 11 on Windows 10.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.