SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have created a list in my SP 2010 site via the Create List using Import Spreadsheet option. Unfortunately, for whatever reason (despite the fact that I have formatted my excel document all the same), some columns end up with some markup/formatting that carries over to the SP list and some dont.

Secondly whenever I create a new row in the list, all text is formatted with a grey color by default. I want all the text to be black. Short of manually making each field a rich text field and changing the text to black, is there any way to make all the text in all the columns of all the rows black? I would hope that SP would provide SOME styling options like this by default but I dont see any such option. Does that mean you MUST alter the sites css in SPD? If so where do i find the property/file that controls the list?

share|improve this question

List -> List Settings -> Come to bottom You'll find View, There is default view "All Items", click.

Then you 'll find style at that page, SP presents you some style options. Maybe they are useful to you. I'll check how to edit style .

share|improve this answer

To change the font color on the datasheet view

site actions -> site setting -> Look and Feel -> Site Theme

Scroll down to the Text Background. Change "Dark 2" to #000000 which is black

This will make the font in the datasheet black.

This link has a decent explanation of what the some of the other settings do. Scroll to this section: "Where the Theme Colors Appear in SharePoint"

share|improve this answer
The "Site Actions" options will change everything on that site, not just your list. – user37328 Dec 31 '14 at 13:05

The reason some fields are formatted and others are not is because I suspect some of your columns are multi-line text columns with Rich Text (or Enhanced Rich Text), which inherit the formatting of the data you imported, while your other columns are plain text (and use the SP2010 default font). Make your MLT fields plain text and all will have the same fonts (or apply the default font to the data you are importing before importing it).

share|improve this answer

Check this link may it helps..

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – John Chapman Dec 15 '12 at 3:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.