Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

After uploading a document to a SharePoint 2010 library, a blank dialog window is being shown instead of the letting me edit the items properties. Has anyone seen this before, I cannot figure out what is going on.

Thanks,

Update: After doing a little more research it looks like its returning a 404 page not found error. Any ideas?

share|improve this question
    
Was there any customization done to the New Item page? Any custom content types in play here? –  Mike Oryszak Jul 8 '10 at 18:06
    
No. The list I first noticed it on was the Site Assets list which is a system generated list. –  Eric Maurer Jul 21 '10 at 19:29

4 Answers 4

up vote 1 down vote accepted

I finally figured out the solution to my problem. When the site was 2007 I had created a copy of the gears.aspx page that was adding in a style sheet reference for a custom branding solution. The 2010 site still uses the gears.aspx for long running operations, but it does not work the same way it used to. When I deployed my custom branding solution it replaced the gears.aspx page and caused the redirect problem after an item was uploaded. Also the page was not actually trying to prompt for metadate on the document it was just trying to refresh the page to show the newly added item in the list. I guess I should have listened when they said to not modify files in the Layouts folder :-)

share|improve this answer

It sounds like your edit form has been deleted or corrupted. Open the document library in Windows Explorer view, with hidden files visible. Open the "Forms" folder and check for "EditForm.aspx".

If you don't see it, create a new Document Library with the same columns and copy EditForm.aspx from there.

And if that doesn't work, copy all your files into the new document library and delete the old one.

share|improve this answer
    
I checked the libraries, and the edit form is still there. I can also go in and edit a document without any problems. I only get the 404 error when I add a new item to the library. – Eric Maurer 0 secs ago –  Eric Maurer Jul 21 '10 at 19:28

Do you have a custom EventReceiver on this document library or content type? This may be interfering or trying to load a different EditForm.aspx.

share|improve this answer

I had this same problem. I had a content type on the library with a template of document.doc. I changed it to document.dotx and it solved my upload problem. I'm not sure why it worked because the upload was not even using this template, but the problem was solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.