Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a custom search results page. In 5 environments across dev and QA we can use this Search Settings site collection administration page (_layouts/enhancedSearch.aspx) to specify:

  • Do not use custom scopes
  • Do not show scope dropdown, and default to contextual scope
  • Our own custom site collection search results page

I actually set the site collection search results page using PowerShell (yes, it is really "TRAGET" in the property name):

$web.AllProperties["SRCH_TRAGET_RESULTS_PAGE"] = $searchResultsPage  
$web.Update()

Unfortunately, in our UAT environment this doesn't work. When viewing the Search Settings page, it all looks correct, but the scopes drop down shows and clicking on search takes the user to the OSSSearchResults.aspx page.

I have seen before where changing these settings can take several seconds to actually work, but this was done yesterday and we have just tested after doing an IISRESET to no avail.

Is there any additional trick to getting this to work? We created the site collection using our scripts and know that the masterpage is using the standard search box. This is SharePoint 2010 Standard if that makes any difference.

share|improve this question

2 Answers 2

Follow these additional steps and change the target search results page:

1) Go to your search page and click Edit Page.

2) Right click Search Box web part and select Edit Web Part.

3) In the Panel, expand Miscellaneous and find "Target search results page URL" textbox and put your complete search page url.

4) Click Apply and then OK.

There's a "Site Collection Search Results Page" field which is used for configuring the search results page used for contextual searches (such as "This Site"). It can be found by doing the following:

1) Go to your SharePoint site collection.

2) Select "Site Settings" from the "Site Actions" menu

3)Go to the "Site Collection Administration" section and select "Search Settings" The field "Site Collection Search Results Page" will be listed on the bottom. The default value is

/_layouts/osssearchresults.aspx, change this to your custom search page url.

Let me know the results.

share|improve this answer
    
Thanks for offering your advice. The "Search Settings" page is the "_layouts/enhancedSearch.aspx" page I mentioned further above so I've already done your second recommendation. I'll look at the first recommendation when I get access to the UAT environment later today. –  Kirk Liemohn Jun 21 '12 at 18:49
    
For our environment, the search box is never in a web part zone. It is on our masterpage and is also on the OSSSearchResults.aspx page. We try not to use the latter, but that is where the user is currently redirected. So, there is no opportunity to edit the web part. –  Kirk Liemohn Jun 22 '12 at 0:17
up vote 0 down vote accepted

It turns out that this UAT environment is somewhat corrupt in that it has remnants of FAST even though this environment is not using FAST (I can get my Full Text SQL queries to work if I go directly to my custom search results page).

I didn't have access to the environment before and was sending emails back and forth with someone who did. However, in a screen share today I noticed that the site collection administration settings showed 3 FAST links and not the regular Search Settings links. My theory is that the Search Box web part is a FAST search box web part and we need to make sure the original search box web part is given a higher priority ("sequence" delegate control setting).

So, one answer is don't used a messed up environment that has remnants of FAST. To fix our environment we simply had to activate the "SharePoint Server Enterprise Search" and or "SharePoint Server Site Search" feature(s) for our web application (scope = SPWebApplication).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.