Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have seen this question asked before (not here) but have never seen anyone with a genuine answer, usually people provide lots of info surrounding how Sharepoint has a different timezome for each Web, User etc but that is NOT my question.

VM is setup to be on CET - (UTC+01:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna. This makes sense as I am in Europe. The clock currently reads 9:57 AM.

Sharepoint Central Admin just started a job at 12:57 AM. Indeed it thinks it is 12:57 AM. This, if I am not mistaken, is PST? The timezone the VM would have been using when Sharepoint was installed.

My questions then:

1) Why is Central Admin on PST not CET when my server is on CET? Is it always PST, or is it locked to the timezone selected on the server when installed? Either seems plausible but neither very acceptable.

2) How can the timezone of Sharepoint be updated short of reinstalling? Or will even that not work?

share|improve this question

2 Answers 2

up vote 7 down vote accepted

In 2010 Go to http://centraladminsite/_layouts/regionalsetng.aspx and change in there. This is hidden by default, but is part of the standard regional site settings.

share|improve this answer
    
Ah of course! For some reason I struggle to see Central Admin as a SharePoint site of its own managed using the same settings pages as any other SharePoint site. Cheers! –  robwilliams Oct 18 '12 at 8:07

You can change the Central Admin Time Zone from here:

Central Admin -> Application Management -> Manage Web Applications -> SharePoint Central Administration v4 (The Central Admin Web Application) -> General Settings -> Default Time Zone

share|improve this answer
    
I tried setting the Default Time Zone for the Central Admin application but this doesn't seem to have any effect on the scheduling of timer jobs. I rebooted the VM too. It seems like the timer service is fixed to the time zone of the machine when Sharepoint was installed? –  robwilliams Jun 19 '12 at 14:37
    
I guess the process is more complicated than I initially thought. Have a look here: blog.azaleos.com/sharepoint/Lists/Posts/Post.aspx?ID=20 –  Vardhaman Deshpande Jun 19 '12 at 16:25
    
Thanks to this thread. It fixed my same kind of issue today. –  user21898 Jan 10 at 22:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.