Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to sync users from our AD to SharePoint. Currently I can not start user profile import because I get the following error all the time.

Error

"Cannot navigate to the requested page while User Profile Synchronization is running. Please wait for the current Sychronization run to finish"

The error is clear but this error is showing up all the time for a week now; is there a way to stop it or what am I doing wrong? I have restarted the server with no luck.

share|improve this question
    
which version of SharePoint are you running? How many servers? Are you using domain accounts for each of the services? –  Mike Oryszak Jul 7 '10 at 14:57
    
sorry for lack of info. Sharepoint 2010,farm server-not standalone,yes one domain account for all sp services –  cranfan Jul 8 '10 at 5:25
    
Please don't forget to put the version of SharePoint as a tag in your questions. –  Robert Kaucher Nov 1 '13 at 14:23
    
whats the current build of the farm, or latest CU installed? –  David Lozzi Nov 1 '13 at 19:29
add comment

3 Answers 3

Please read this article by Harbar: http://www.harbar.net/articles/sp2010ups2.aspx there are full definition of your problem and ways to resolve it

share|improve this answer
    
Thanks Vitaly,i'll try and write what happens.It looks like a very detailed and informative post. –  cranfan Sep 22 '10 at 5:40
    
This is an excellent article. I saved it out in case it ever goes offline! –  BGM Jun 28 '12 at 21:28
add comment

Open the MIISClient:

C:\Program Files\Microsoft Office Servers\14.0\Synchronization Service\UIShell\miisclient.exe

Check for any detailed error messages and cancel the current run.

share|improve this answer
    
it says unable to connect to Syn. Serv. some possible reasons are: the service is not started. your account is not a member of a required security group. my account is domain and local pc admin btw. –  cranfan Jul 12 '10 at 6:38
    
Corbett's suggestion to add your account to FIMSyncOperator worked when I encountered the error opening miisclient –  Tom Resing Dec 3 '10 at 20:29
add comment

Aside from making sure the FIM services are started, to open the miisclient you may need to add your account to the FIMSyncOperators group, log off and on.

share|improve this answer
    
This is true, but not directly related to the question. –  Tom Resing Dec 3 '10 at 20:28
    
I do not have FIMSyncOperators group neither on server or AD –  user5329 Oct 20 '11 at 16:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.