Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

i am working with SharePoint 2010. I am trying to create a document library (for excel documents) using features. I added a List Instance and a module that holds my document to be added to my document library. All works fine but When I try to open the excel files from the newly created library they won't open neither in browser directly nor in Excel Web Access web part.

I get the following error on opening the file in browser itself.

Unable to Process request.Wait for few minutes and try performing this operation again.

Element.xml for module

<?xml version="1.0" encoding="utf-8"?>
<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
<Module Name="ExcelTemplates" Url="Lists/Templates">
<File Path="ExcelTemplates\Sample_doc.xlsx" Url="Sample_doc.xlsx"  Type="GhostableInLibrary" />
<File Path="ExcelTemplates\Test_Doc.xlsx" Url="Test_Doc.xlsx" Type="GhostableInLibrary"    />
</Module>
</Elements>

Element.xml for List Instance

<?xml version="1.0" encoding="utf-8"?>
<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
<ListInstance Title="Templates"
            OnQuickLaunch="TRUE"
            TemplateType="101"
            FeatureId="00bfea71-e717-4e80-aa17-d0c71b360101"
            Url="Lists/Templates"           
            Description="Excel templates ">
</ListInstance>
</Elements>

Please help.

Regards VB

share|improve this question
add comment

1 Answer 1

Ok I got the problem.Actually Excel services were not running for that particular web application under which my site was running. Selected the excel services from central admin for my web app and all good. :-)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.