Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When i create a sandbox solution, and i want to use resources in my code, i use sattelite assemblies.

But in my masterpage it seems not to work, i get following error:

Parser Error Message: The resource object with key 'sps_contactus_link' was not found.
share|improve this question
    
Do an IIsreset and the values will get reflected –  user14661 Feb 5 '13 at 10:08

2 Answers 2

are you using embedded resources and accessing them in Sandbox solution likely?

See more details: http://blog.sharepointbits.com/2011/03/localization-in-sharepoint-2010-sandbox.html

share|improve this answer
    
I work like that way, and that works fine in my C# code; but when I want to use it in a master page I get the error. –  Davy Jun 13 '12 at 10:43

If i use

NavigateURL="<% $Resources:Resources.Properties, sps_sitemap_focusareas_link %>"

then i get the following error:

Could not find any resources appropriate for the specified culture or the neutral culture.  Make sure "Resources.Resources.Properties.resources" was correctly embedded or linked into assembly "App_GlobalResources" at compile time, or that all the satellite assemblies required are loadable and fully signed. 

But if i use

NavigateURL="<% $Resources:Properties, sps_sitemap_focusareas_link %>"

then i get the following error:

The resource object with key 'sps_sitemap_focusareas_link' was not found.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.