Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a problem with one of the links in a column of my XsltListViewWebpart. It's working perfectly fine in Firefox, but when I click it in IE, nothing happens.

The code for the link is:

<a onclick="EditLink2(this,82);return false;" href="{concat('/folder1/folder2/Page.aspx?RootFolder=',$thisNode/@FileRef.urlencode,'&amp;SourceID=',$thisNode/@ID)}"><xsl:value-of select="$thisNode/@FileLeafRef" /></a>

Is there a reason why IE refuses to understand this link? I'm puzzled.

edit: I just discovered it only works in IE when I right click the link and select open, or open in new tab. For some reason left click doesn't work.

Thank you very much for your suggestions.

Regards,

share|improve this question
1  
got it. it was the default popup blocker in IE. I apologize for wasting the community's time. –  Amc_rtty Jun 7 '12 at 8:45
    
glad you find the answer. Please answer to your question instead of commenting it. This will allow you to mark the question as answered. –  Steve B Jun 7 '12 at 8:47
add comment

1 Answer

up vote 2 down vote accepted

The default popup blocker in IE was creating problems. I added an exception for the website in its settings and the problem is now solved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.