Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I recently switched SharePoint 2010 from http to https using URL rewrite and a purchased wildcard certificate. Since then, any time a user attempts to Edit Document in Application (i.e. Word, Excel, etc.) from SharePoint the document always opens as read only. I have tried various settings in IE in reference to Trusted Sites and Local Intranet as well as various other options provided by Google with no success. I'm thinking this may have something to do with the redirect and Anonymous access, but not sure. In addition, the site is set to Permissive, the database isn't full and it's not read only, and the hard drive isn't full. What are my other options besides converting back to http or uninstalling and re-installing?

share|improve this question
add comment

1 Answer 1

URL rewriting is not supported and certainly a not best practice with SharePoint 2010. Why using URL rewriting and not standard AAM and extending Web Applications?

share|improve this answer
    
I used the alternate access mappings as well. The reason for choosing URL rewrite instead of requiring SSL from IIS is for compatibility issues. Any other thoughts? –  studentofsecurity Jun 5 '12 at 11:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.