Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

As of now when I add users to the OOTB Sharepoint 'Members' group with contribute permissions they are able to delete web parts as well. I tried two suggestion I found online:

  1. Go to site permissions>>permissions levels>>contribute>>remove 'Add remove personal web parts' AND it did not work.

enter image description here

  1. Edit web part and uncheck "Allow Close". The option is grayed out.

    enter image description here

How can I get around this issue?

I am open to any other suggestions/approaches to fix this issue as well. Thanks

share|improve this question
    
Can you try removing the "Edit Item" permissions from the permission levels and check again. It is advised you use a separate SharePoint Group with Read level access on the site and use custom permission levels mapped to this group explicity using unqiue permissions on the required lists or libraries.Its a general best practice. In the custom permission level just check the ones that are needed. –  Arko D Jun 4 '12 at 13:59
    
Thanks. I agree with you and that is exactly what I tried. Here is the catch though. I have to give users the "Edit Items - Edit items in lists, edit documents in document libraries, and customize Web Part Pages in document libraries." for them to be able to edit and delete and not just add documents or list items. And unfortunately when I do this, they seem to be able to delete web parts as well. If I remove this, yes they cannot delete the web parts but they can only add documents and items but not edit or delete them. Any thoughts? –  user7400 Jun 4 '12 at 14:05
    
I think you should separate library for holding webpart pages and separate library for uploading and editing documents. Give permissions to edit/delete documents to the group for document library and give read only/add pages permission to the pages library. That way you can segregate and organize security more effectively. –  Arko D Jun 4 '12 at 20:57
add comment

2 Answers

I would create a permission level "Contribute without Delete" (be sure uncheck the delete option when creating this permission level). And use this permission for the custom group you have. Then add this group to webpart or list or library.

share|improve this answer
    
Tried it. Even if I uncheck the "delete" option the "edit" options seems to give users enough permissions to delete the web part. –  user7400 Jun 4 '12 at 14:18
add comment
up vote 0 down vote accepted

Right, I got it fixed!

I went to Site actions>>Manage Content And Structure>>Site Pages>>select (not click) "Home.aspx"....

You could now modify Group permissions to read only or choose to modify granular permissions likewise.

Once done, you should now notice that members of the home members group will neither be able to edit web parts nor edit the home page even!

share|improve this answer
    
After you select the "home.aspx" by checking the box, how do you modify the permissions? Do you click 'Manage Permissions' from the ECB? –  PurpleShadow Oct 17 '12 at 13:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.