Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm working on a workflow that needs to pause for a few minutes and then resume. My problem is that it never resumes after the pause. This is the workflow I'm testing it on.

Log start to the workflow history list
Pause for 0 days 0 hours 5 minutes
Log stop to the workflow history list
Stop the workflow and log completed

It never logs stop. If I remove the pause the workflow works correctly.

I've read about a hotfix that has to do with timer in sharepoint http://www.microsoft.com/en-us/download/details.aspx?id=21066 . But I wasn't able to install it so I think it doesn't apply to my version of SPD.

Any ideas?

ps. cross post from stackoverflow after I found out about this site.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

It wouldn't be a SharePoint Designer issue, but one with the SharePoint server itself.

Check Central Admin to see if the Workflow, Workflow Autocleanup, and Workflow Failover timer jobs are ok for your web application.

If you run a stsadm -o getproperty -pn job-workflow -url http://sp2010 do you get <Property Exist="No" />?

share|improve this answer
    
Thanks a lot, Workflow Autocleanup was missconfigured –  MaurizioPz Jun 4 '12 at 8:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.