Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

For all the Web Parts on my SP 2010 team site wiki page, the "Hidden" option is greyed out (under Edit Web Part > Layout).

How can I activate this option?

share|improve this question
    
I changed IsVisible property by exporting the webpart file. I set it false from true. But it does not show the web part even in edit mode. –  user4009 Jul 6 '11 at 19:33
    
I just checked with an HTML Form WebPart and it worked. The WebPart imported properly and is invisible. To see if the WebPart is there open the page in maintenance mode by appending ?Contents=1 to the page url. –  Sig Weber Jul 11 '11 at 21:47
    
I forgot to mention: yes it is invisible, even in edit mode of the page. I guess that's the reason why Microsoft has disabled this feature in the UI. –  Sig Weber Jul 11 '11 at 22:58
add comment

1 Answer

up vote 1 down vote accepted

I ran into the same issue a while ago. As a temporary workaround I exported the WebPart into a DWP file and edited it with a text editor (I prefer Notepad++). Once done I imported it back and added it to the page.

share|improve this answer
    
What edit did you do? Change to the IsVisible property, like Prachi? –  Christophe Jul 7 '11 at 4:25
    
Yes, toggle the IsVisible to show/hide a WebPart. If you are in doubt create a new Document Library and select "Web Part Page" as document template. Then create a new WebPart page and add the e.g. HTML Form WebPart and modify the properties to hide it. Then export it and import it where you want to have it. –  Sig Weber Jul 11 '11 at 21:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.