Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a publishing site, but want to get rid of that "summary links" box that comes up on the homepage. How can I do this (preferably without sharepoint designer, as I am developer/infrastructure guy)?

Thanks

share|improve this question

4 Answers 4

To go in a different direction, you could simply use CSS to hide the Summary Links box.

  1. Add a web part to determine the class or ID of the element that contains the Summary Links box. Todd Bleeker has a good example here of "Style Under Cursor" JavaScript that you can put in a Content Editor Web Part: http://mindsharpblogs.com/todd/archive/2005/10/25/798.html

  2. Add a Content Editor Web Part on your page, with CSS that hides the DIV tag in question. Let's say you learned from step one that the ID of the div that contains the Summary Links box is ms-summary:

    <style type="text/css">
    <!-- Hide Summary Links box -->
    .ms-summarylinks {
    display:none;
    }
    < /style>
    

You may have to use visibility:hidden.; instead of display:none.

  1. Remove the Style Under Cursor Web Part from the page.
share|improve this answer

I strongly dis-advise to change layout if you simply can choose another one.

In browser go to site collection of your publishing site Click "Site actions" in ribbon --> from its drop-down-list choose "Manage Content and Structure" --> in the left side bar tree navigate to your publishing site entry and under it open "Pages" --> on the right open default page (or page you need to change) --> Choose "Page" tab on the ribbon --> Click "Edit" in ribbon --> Under "Page Layout" tab choose from drop-down-list the layout without "Summary links", for eample "Body only" --> clik "Save and close"

enter image description here

share|improve this answer

option 1: On the site actions menu select "Edit this page", On the right of the summary links webpart a small down arrow appers click on that and delete the webpart(do not close it).

option 2:

In the Page URL at the end type(?contents=1) in the webpart maintenance page select the Summary Link webpart and delete it.

Regards, Sudan

share|improve this answer
    
I don't think Summary Links is a webpart in a webpart zone, or your answer would be correct. I don't use Publishing, so I can't confirm. –  CigarDoug Jan 21 '13 at 15:52

You have to modify the page layout (or choose another page layout without a summary links box). You can edit the page layout only with SharePoint Designer or you can build a solution with a feature in Visual Studio to create your own page layout.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.