Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have used the sharepoint farm configuration wizard to setup all services under spfarm account and everything works fine. However I am having trouble with Searching for people. Here is the link I have followed: http://www.dotnetfunda.com/articles/article1259-enterprise-people-search-in-sharepoint-2010.aspx

Although I have run a successful User Profile Synchronization, I get the following error while checking the crawl log:

sps3://sharepoint-intr

sps3://sharepoint-intr:10874

What am I missing?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Two things, the start address for Profiles should be sps3://mysitehost. The permissions on the User Profile Service for the default crawl account has to be allowed to "Retrieve People Data for Search Crawlers". Go to Central Administration | Application Management | Manage Service Applications. Select the User Profile Service Application (don't click the link just select the app). Choose Administrators from the ribbon. Add the Crawl Account and check "Retrieve People Data for Search Crawlers.

Rerun the crawl. M

share|improve this answer
    
I have already given the crawl account "Retrieve People Data for Search Crawlers" permission. Right now I have it set as "sps3://servername" (which was added by default). I am not sure what you mean by MySiteHost. Is ther a way for me to find this? –  user7400 May 25 '12 at 12:23
    
If you are referring to the web application hosting my sites, well I dont have my sites configured yet. –  user7400 May 25 '12 at 15:40
    
Was giving the wrong account "Retrieve People Data for Search Crawlers" access! Got it working. Thanks all. –  user7400 May 25 '12 at 18:38
add comment

Add a brand new crawl job and do a full crawl.

share|improve this answer
    
Oh Im past that. I have tried a new content source with "sps3://servername", a new crawl job and a full crawl a couple of times. The same error though. –  user7400 May 24 '12 at 16:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.