Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a SharePoint 2007 publishing portal that started throwing an error when user's click the Sign Out link. This started happening just this week and I can't tell what changes that have been made that caused this error. I've also noticed that links are no longer redirecting to the correct login page. I've set up FBA using the ADMembershipProvider, along with the LdapRoleProvider.

The direct link to the login page displays without error.

http://portal/_layouts/useraccounts/login.aspx?ReturnUrl=%2f

but a link to http://portal/ will redirect to http://portal/_layouts/Authenticate.aspx?Source=%2f and will displays "Unknown Error". Also, if I remove the query string parameter from the above link, http://portal/_layouts/useraccounts/login.aspx, this also throws an "Unknown Error".

Nothing is getting put in any of the Windows Event logs, but the SharePoint logs has this error.

Exception Type: System.Web.HttpException Exception Message: The referenced file '/_catalogs/masterpage/custommaster.master' is not allowed on this page.

This had been working previously, and there hasn't been any changes to the master file. I'm really stumped as to why this stopped working. If anyone has any idea's on what might be failing, that would be greatly appreciated.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I found the cause of this issue was that someone had entered a master page in the Pages section of the web.config (ok, that someone was me).

<pages masterPageFile="/catalogs/masterpage/custommaster.master" .../>

A few weeks ago, I was trying to change the default error page so it used my custom master page and forgot to take this segment out. Anyways, don't do that.

share|improve this answer

Sounds like the authenticate portion of your web.config has been changed. It should look something like this:

 <authentication mode="Forms"> 
   <forms loginUrl="/_layouts/useraccounts/login.aspx" /> 
 </authentication> 
share|improve this answer
    
That's what I had thought, but the web.config has this exact section (which I should have included in my original post). It's almost like something is causing SharePoint/asp.net to ignore this section. –  shannon.stewart Jun 25 '10 at 13:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.