Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have some hand crafted XML files we use for various rss needs. Whenever a dev updates the file, SharePoint Designer adds an UTF-8 byte order mark to the beginning of the file causing some parsers to complain about it. Currently, I can open the file in vim or a hex editor and remove the mark, but is there a way to make SharePoint Designer not do this?

Edit: Were using SharePoint Designer 2007. However, we do plan to upgrade to SharePoint 2010 later, so if there is any insight there, I would be very appreciative.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I believe you can fix this by opening the site in sharepoint designer, going to "Site Options" -> "Language" and choosing a "Default Page Encoding" other than UTF-8.

share|improve this answer
    
I went with US/Western European ISO encoding, and that got me where I need to go. I appreciate the input. –  Robert Silvie II May 23 '12 at 22:01

You can change the XML editor in the Application Options under Tools to Notepad inside SharePoint Designer. Try that and see if SharePoint Designer behaves.

share|improve this answer
    
I didn't have to use Notepad after all, but your answer sent me in the right direction. Cheers. –  Robert Silvie II May 23 '12 at 19:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.