Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I just installed fresh install of windows server 2008 R2. Then I installed wss 3.0 64 bit in the server. Install finished sucessfully, i installed standalone version with Windows Internal Database. Then i created a web application, then Top Level Site collection with Team Site Template asssigned my account as Site Collection Admin.

It completed sucessfully, then i went in and made changes in host file to host it from local host. I ran iisreset after that, then went in tried to open the site, it gave me windows authentication.

So now it didnt let me in, then i went to iis and disabled windows auth and enabled basic it finally let me in and can browse the site.

I dont know why is it doing this, any insights would be greatly appreciated.

Thank You

share|improve this question
    
guessing you are facing a http 401.1 or 401.2 error ? please check in the iis logs (search for status and substatus). –  Steve B May 23 '12 at 14:13
    
Hello Steve thank you for you reply, but i dont see any error code in browser or in iis log files. its weird that my authentication works fine in central admin. –  octopus May 23 '12 at 14:27
    
I bet your central admin is accessed using http://servername:port, while your app is accessed using a custom host header (http://www.corp.com/). am I right ? –  Steve B May 23 '12 at 14:31
    
Yeah i am using custom host header abc in port 80 –  octopus May 23 '12 at 14:32
    
I'm still believing you have either a 401.1 or 401.2 error in IIS log file. –  Steve B May 23 '12 at 14:45
add comment

1 Answer

up vote 1 down vote accepted

When you want to use custom host headers with windows authentication, you have to disable loopback check or whitelist the host names.

Follow this Microsoft KB.

I highly advise you to use the second method (white list) on production servers, as the first method shut down a security mechanism.

share|improve this answer
    
Applying DisableLoopbackCheck worked !!! thank you. –  octopus May 23 '12 at 15:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.