Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have both SPD 2007 and SPD 2010 installed on my machine. When i open a SharePoint 2010 site in IE and try to click on the 'Edit in SharePoint Designer' menu item under the 'Site Actions' menu. It tries to open the page in SPD 2007, not in SPD 2010.

How can i change the link to open the pages in SPD 2010 instead of SPD 2007 ?

share|improve this question

1 Answer 1

This is related to the internet explorer and system level settings instead of settings related to SharePoint.

In IE, go to Tools > Internet Options > Programs and see if "Microsoft SharePoint Designer 2010" is selected as the "HTML Editor".

Othewrwise go to set default programs from the control panel and set SPD 2010 as the default HTML Editor.

Try this out and let us know if this works.

share|improve this answer
    
In IE it shows "Microsoft Office SharePoint Designer" under HTML Editor. And under 'Set default programs' i can not see "SharePoint Designer 2010". –  Amit Tyagi Jun 28 '12 at 13:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.