Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am using the following url to display an excel document in the browser:

sharepoint-server:29769/_layouts/xlviewer.aspx?id=http://sharepoint-server:29769/Documents/Cancer/Graphs.xlsx&range=Brain!A4

The problem I'm having is that when I load the url in the browser it returns a download dialog box as opposed to displaying the excel document in the broswer(IE7). What I had noticed is that if I point the id parameter to a url that does not contain a port number it seems to work. Unfortunately at this moment in time I'm unable to have the address put on port 80 and need to fix the issue fairly quickly.

Any tips would be much appreciated. Thanks.

share|improve this question
add comment

1 Answer

For sharepoint I think you need to enable excel services for the web application running "29769" port through the Central Administration. As you say for port 80 it works , then essentially it means excel services has been configured at the farm level and renders the documents in the browser.

You can validate this using http://yoursite:29769/_vti_bin/ExcelService.asmx

Additionally, please ensure if alternate access mapping are set correctly if your web front servers are running behind nlb. Internal urls must be configured for the intranet zone for the web application running on "29769".

Thirdly, please validate if the browser file handling setting has been set to permissive instead of strict in the web application general settings for the web application running on 29769.

share|improve this answer
    
Many thanks for your response. I can confirm that Excel Services is running on 29769. Also I'm not using nlb and finally I'm using SharePoint 2007 and I can't seem to locate broswer file handling settings - I think this applies only to SharePoint 2010. Any other advice would still be much appreciated. –  Imran Azad May 22 '12 at 13:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.