Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have a corporate internal portal with lot of subsite and document library for various department/BU.

When a user tries to open a excel file from a document library it opens in Excel client from my machine. But for some of the users they automatically redirected to the _layouts/XLViewer.aspx where the file tries to open in Browser. The requirement is to open the file in excel client instead of XLViewer.aspx.

How to I isolate this problem and fix this issue.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

You can control this on a per site or per library basis for setting default behavior.

For library, go to Library Settings -> Advanced Settings and select your default behavior of open in browser, open in client, or default (which is usually open in browser).

For an entire site collection there is a feature called, plainly enough, Open Documents in Client Applications by Default.

Note the ECB menu on items and in the Ribbon also have options to open in browser or open in "client".

If you are using SharePoint 2010 or lower, the open in client behavior is dependent on ActiveX controls in IE. If you are not using a tier 1 browser you are usually prompted with either an error or the dialog to download the item.

share|improve this answer
add comment

Please follow the steps outlined here. This will be applicable through out the farm and all files will be downloaded on the client system instead of opening them in the browser.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.