Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a sucessful implementation of incoming email in my environment. I encountered an issue today however, after a change I made to the location of the SMTP "Badmail, Drop, Pickup and Queue" folders that service this feature.

We wanted to store these folders on a secondary drive instead of keeping it on the primary drive. I found a set of scripts that would handle this move:

cscript.exe c:\inetpub\adminscripts\adsutil.vbs set smtpsvc/1/pickupdirectory "M:\SMTP Mail Server\pickup"
cscript.exe c:\inetpub\adminscripts\adsutil.vbs set smtpsvc/1/queuedirectory "M:\SMTP Mail Server\queue"
cscript.exe c:\inetpub\adminscripts\adsutil.vbs set smtpsvc/1/dropdirectory "M:\SMTP Mail Server\drop"
cscript.exe c:\inetpub\adminscripts\adsutil.vbs set smtpsvc/1/badmaildirectory "M:\SMTP Mail Server\badmail"

So once I moved the directories the emails would arrive in the new location "drop" folder, however they would not be picked up by the sharepoint timer job that runs once a minute. I looked into the ULS log on the server and the job was executing properly.

I decided to test putting those emails into the old drop folder location "c:\inetpub\mailroot\" and they were delivered.

My question is...obviously something isn't syncing in my adjustment with SharePoint while IIS is taking the new setting something in SharePoint isn't. Is there a way to adjust this in SharePoint or nothing that can be done.

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

I think you have to re-enable the incoming mail service within the CentralAdmin.

At least on initial setup it asks you where you have your drop folder or if SharePoint should automatically detect the local SMTP service.

share|improve this answer
1  
This worked, I disabled the incoming email feature through CA, then re-enabled it. Once this was done the folders worked correctly on my secondary drive. –  Jacob A May 21 '12 at 17:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.