Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Most of my users are on Office 2007, my SharePoint installation is 2010, and we all use IE8. I currently have "Require Check Out" on my document libraries set to "No". I have a page in one of my site collections which is essentially a list of hyperlinks to frequently used files by a specific department. When someone on Office 2007 clicks on any of the links, the file opens in the client application as Read-Only, which is fine. What is not fine is that the information bar that would normally allow you to click a button to enable editing of the document is not there.

What do I have to change to allow my users to edit documents when they've opened those documents with a link from a web page?

Edit: This is not an issue on my machine, which has Office 2010 installed.

share|improve this question

5 Answers 5

Maybe this MS KB article could help finding suitable solution (the cause and solution part of article) http://support.microsoft.com/kb/2661910

share|improve this answer

Created the DWORD key hoping it would clear this up but appears to have no affect. The only solution we have found is turning on check in / check out as a requirement. I would prefer a soultion that does not require that if possible as some of our users do not want that feature enabled. Strangly enough clicking the document from the library itself opens with Edit on the information ribbon in office, same as if you say "Edit in Excel" off ECB. We are only getting the Read Only, No Ribbon when we try and use a link that goes straight to the .xls file which users frequently use in Announcement webparts or links webparts.

share|improve this answer
    
It's not clear if you're suggesting enabling require check out as a solution, or if you are also looking for help with a similar problem. In the latter case, I would suggest creating a new question (and linking to this one as related). –  lgaud Jul 5 '13 at 14:21

I have this same problem. I found a workaround where you edit the setting on the document library to require documents to be Checked Out. When you do this, the document still opens Read-Only with no "Edit DOcument" button, but you now have a "Check Out" button which checks out the document and oens it for editing. There are a few more button-clicks to save and check-in, but so far it appears to work!

share|improve this answer
up vote 2 down vote accepted

After a fair amount of Google-fu I finally found a MS KB article that helped.

You have to open Regedit.exe and add a new DWORD value OpenDocumentsReadWriteWhileBrowsing to HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Internet and set it to 1. Now clicking on a link will open the file in edit mode, which is fine for my purposes.

share|improve this answer
1  
YOU ARE MY HERO! –  Daniel Ziga Jan 25 '13 at 20:20
    
regedit answer definitely helped, but must be set for the correct office version. 14=2010 –  user19465 Sep 11 '13 at 13:59

Are you using internet explorer or another browser? Often time this can be fixed by adding the URL of your SharePoint instance to the Trusted Sites in your browser. Instructions for IE:

  1. Click Internet Options
  2. Click the Security Tab
  3. Click Trusted sites
  4. Click the Sites button
  5. Paste the URL of your SharePoint site to add it to the zone
  6. Click OK

As for the URL to the document, something like this might work. I don't have your environment to test, but hope this will get you closer to the answer.

<A href="#" onclick="editDocumentWithProgID2('http://[the.document.url]', '', 'SharePoint.OpenDocuments', '0', 'http://[the.site.url]', '0')">Edit Document</A>
share|improve this answer
    
We are using IE8 throughout the office, and I just tried adding the URL to Trusted Sites with no luck. I haven't tried altering the URL of the document link, but even if it works it's not an ideal solution as most users can edit the page that contains these links and trying to explain this to them would be a problem. –  newuser May 21 '12 at 18:01
    
Just tried altering the URL; no dice. :( –  newuser May 21 '12 at 18:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.