Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When a specific user adds or updates an item in a specific list, an alert automatically created for that user, set to notifiy them of changes/inserts to "All Items". This shouldn't be happening, but for this one user, it is. If we delete the alert, and the user goes back to the list and creates another item, the alert is created again. Why would this be happening? And to only one user (apparently) ?

Update: OK, no custom event receivers on the list or on the site. Here is the spalert object in powershell. This alert is different than all others because it has a blank alerttemplatename and alerttemplate. (All other alerts have a template and templatename.)

  • Title : Action Items: All items
  • AlertTemplateName :
  • AlertTemplate :
  • Filter :
  • Properties : {}
  • ID : 1bba691e-a8d0-462d-8eb0-573b2ea9e573
  • ListID : fe119f4f-8e6e-4839-bc14-30e8dc17bbd9
  • MatchId :
  • ItemID :
  • ListUrl : Lists/Action Items21
  • List : Action Items
  • Item :
  • AlwaysNotify : False
  • DeliveryChannels : Email
  • AlertType : List
  • EventType : All EventTypeBitmask : -1 AlertFrequency : Immediate AlertTime : Status : On User : NCxxx\cfxxxx UserId : 849 DynamicRecipient :
share|improve this question
    
Is this an Alert or a Workflow Email? –  Dave Wise May 18 '12 at 21:49
    
No event receivers by any chance added by custom developments or 3rd party components? –  C. Marius - MVP May 19 '12 at 6:03
    
Dave, the issue is with alerts being unexpectedly added. But, there are workflows attached to the list. The workflows are simple Designer types, send email on status change. –  1c1cle May 19 '12 at 13:51
    
C. Marius, I'll look into custom event receivers. Why do you think this could the source of the issue? And only for one user? –  1c1cle May 19 '12 at 13:52
add comment

1 Answer 1

up vote 0 down vote accepted

nevermind. There was a custom feature installed in the site back when it was in 2007, and it was enabled by default after the migration to 2010.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.