SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using steps for installing RBS on SP Foundation 2010

I am installing RBS.msi on my content database but cannot see the tables by RBS in it after installation, I have checked and I am running the command prompt with admin priveleges but still no tables, why ?

Let me know Thanks.

share|improve this question
What tables are you looking for? – Wictor Wilen MCA MCM MVP May 18 '12 at 14:25
the tables which are created by the RBS client library setup like eg: mssqlrbs_nameoftable – RHM May 18 '12 at 14:41
Ok, please give use more details about what steps you've done and any (error/information)messages. – Wictor Wilen MCA MCM MVP May 18 '12 at 14:50
I enable the filestream on sql server instance on which sp 2010 is running its content db. Then I executed the four queries to enable Blob storage in sql server. Then I download the RBS Client library setup and run it through command prompt with admin rights. I checked its log files and I can see it says that setup completed successfully but still I cannot see the RBS tables in my sp sites content db – RHM May 18 '12 at 14:55
Have you executed the required PowerShell on the CDB? – Wictor Wilen MCA MCM MVP May 18 '12 at 15:00
up vote 2 down vote accepted

Yeah, this is a frequent issue. The command prompt didn't work for me either. Just double click on the MSI and walk through the wizard. It'll work correctly then.

share|improve this answer
This worked for me! Thanks David. – RHM May 22 '12 at 10:44
Excellent, glad I could help! – David Lozzi May 22 '12 at 13:03

One user had a similar issue while installing & configuring RBS. I've described the process here Installing RBS which also includes some troubleshooting steps.

Have a look and let us know if that helps you troubleshoot!

share|improve this answer
I have tried it but no success yet, No tables found still – RHM May 21 '12 at 9:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.