Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When the upgrade of 2007 to 2010 took place i started to get errors for my webparts on my website as mentioned below: Error[1]

Web Part Error: A Web Part or Web Form Control on this Page cannot be displayed or imported. The type could not be found or it is not registered as safe.

Show Error Details

[UnsafeControlException: A Web Part or Web Form Control on this Page cannot be displayed or imported. The type could not be found or it is not registered as safe.]
  at Microsoft.SharePoint.ApplicationRuntime.SafeControls.GetTypeFromGuid(Guid guid, Guid solutionId, String assemblyFullName, String typeFullName, Boolean throwIfNotFound) 
  at Microsoft.SharePoint.WebPartPages.SPWebPartManager.CreateWebPartsFromRowSetData(Boolean onlyInitializeClosedWebParts) 
share|improve this question
    
Have you tried re-deploying your webparts after the upgrade to see if it helps? –  Daniel Ziga Nov 15 '12 at 9:07

3 Answers 3

You need to add the web part type as safe control in the web applications "web.config" file and in the configuration > SharePoint > SafeControls section. The general format is like below:

Just replace AssemblyName, AssemblyVersion, AssemblyCulture, AssemblyPublicKeyToken, The class name of the web-part and The class name of the web-part with the information to your web-part.

share|improve this answer

This is usally shown very clear in the Trace logs. Check the LOGS directory on your front ends and search for the error.

share|improve this answer

Here you can find a step by step tutorial to track the error cause: http://www.bluedoglimited.com/SharePointThoughts/Lists/Posts/Post.aspx?ID=189

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.