Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

First time installing SP1 on my test farm and started off installing foundation SP1 first, rebooted and then ran "psconfig -cmd upgrade -inplace b2b -wait" to finish the upgrade.

During this run of the configuration wizard it completed 3 of the 4 stages at 100% but errored out on the final stage prompting me to look through the logs to find the issue,correct it and re-run config wizard.

I looked through the logs and found this reference: " Creating service connection point for this farm ... 05/12/2012 22:04:14 4 WRN Failed to add the service connection point for this farm 05/12/2012 22:04:14 4 INF Entering function StringResourceManager.GetResourceString 05/12/2012 22:04:14 4 INF Resource id to be retrieved is ServiceConnectionPointNotCreatedEventLog for language English (United States) 05/12/2012 22:04:14 4 INF Resource retrieved id ServiceConnectionPointNotCreatedEventLog is Unable to create a Service Connection Point in the current Active Directory domain. Verify that the SharePoint container exists in the current domain and that you have rights to write to it. 05/12/2012 22:04:14 4 INF Leaving function StringResourceManager.GetResourceString 05/12/2012 22:04:14 4 WRN Unable to create a Service Connection Point in the current Active Directory domain. Verify that the SharePoint container exists in the current domain and that you have rights to write to it. Microsoft.SharePoint.SPException: The object LDAP://CN=Microsoft SharePoint Products,CN=System,DC=contoso,DC=com doesn't exist in the directory. at Microsoft.SharePoint.Administration.SPServiceConnectionPoint.Ensure(String serviceBindingInformation) at Microsoft.SharePoint.PostSetupConfiguration.UpgradeTask.Run() 05/12/2012 22:05:42 4 INF Entering function TaskCommon.TraceToPsconfigLogAndUpgradeManagerLog 05/12/2012 22:05:42 4 INF Not spawing off the upgrade job, but rather running upgrade synchronously by calling SPFarm.Local.Upgrade() for inplace upgrade 05/12/2012 22:05:42 4 INF Leaving function TaskCommon.TraceToPsconfigLogAndUpgradeManagerLog 05/12/2012 22:13:31 4 ERR Task upgrade has failed with an unknown exception 05/12/2012 22:13:31 4 ERR Exception: Microsoft.SharePoint.Upgrade.SPUpgradeException: Upgrade completed with errors. Review the upgrade log file located in D:\SPLogs\TraceLogs\Upgrade-20120512-220230-65.log. The number of errors and warnings is listed at the end of the upgrade log file.

I did some digging around to figure out what this connection Point is...apparently it's disabled by defualt if you never make the container but some people have reported the same problem as me...am i forced to create this container just to satisfy this issue?

Or can i just ignore the error and assume my update completed correctly?

Any thoughts?

share|improve this question
add comment

1 Answer 1

Looks like this a common issue. I had same issue after researching why Search wasn't working and only returning an error message. You could fix the issue by following instructions here: http://blogs.msdn.com/b/opal/archive/2010/04/18/track-sharepoint-2010-installations-by-service-connection-point-ad-marker.aspx But, you don't want to leave as is. You can run the psconfig update again (PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures) and update will succeed even without the fix above. It seems that the second run has only the permanent feature install lines (mine was reporting services feature) and must have removed the other features. I am doing this on workspace (free) edition, and my search is working again. I did have to do an IISReset.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.