Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've got 2 site collections. Within 1 site collection, I'm able to add keywords to list items. But I go over to the other site collection list, I can see the keywords and select the keyword, but when save the item, it disappears. I found a keyword that actually saves but when viewing the item in the list, the keyword column shows 'january'. Very strange.

Why would keywords work on a list in one site collection but not in another?

share|improve this question
    
Are you sure you are talking about the Enterprise Keywords option in the list, or is it by any change a different TermStore at site collection level? –  C. Marius - MVP May 10 '12 at 15:36
    
In the list item, there is an "Enterprise Keywords" textbox. That's where I choose the keyword. I also see the keyword in the term store at the site collection level. –  TexasT May 10 '12 at 16:13
1  
I'm not sure if the list was corrupt (it was created from a list template) but what I did to resolve the issue was delete the Enterprise Keywords field from the list, reenabled the Enterprise Keywords option in the list, and then I was able to save keywords on items. –  TexasT May 14 '12 at 19:40
    
it could have happen in a migration scenario or a custom deployment of a feature that tried to rename the column improperly. –  C. Marius - MVP May 14 '12 at 23:52
add comment

1 Answer

Did you ever manage to get this sorted?

I was having the same problem editing list items from a library migrated from an existing SP2010 farm. The Enterprise Keywords field was not updating, but every other field seemed to update OK. I noticed the problem on documents that:

  • Were MS Office docs (specifically .docx)
  • Had a specific Enterprise Keywords value

I have a very strong suspicion its to do with how SharePoint stores it's own metadata in the .docx file itself: http://sadomovalex.blogspot.com.au/2012/12/remove-sharepoint-metadata-from-ms.html. I wish I could say I found what the magic combination was to caused this to fail, but in the end this was my clunky workaround

  1. Open the document in MSWord
  2. Go to Inspect Document -> Tick all options -> Inspect
  3. Remove the following sections: Document Properties and Personal Information and Custom XML Data
  4. Save Word doc
  5. Manually re-enter document properties
  6. Delete offending item from SharePoint list
  7. Re-upload the "cleaned" word doc
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.