SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So far, we had our MySite setup in the same web application as our intranet (http://ourintranet), and had it located under the URL http://ourintranet/my. No personal sites were allowed, we are basically just serving Profiles and Newsfeeds.

We wanted to move the MySite to its own WebApp, so we created a new web application with the URL http://mysite (AAM & IIS bindings are all set up for both http://mysite as well as the FQDN), created a new site collection at the root with the MySite Host template, and lastly updated Central Admin to use http://mysite as the new host.

What happens now is when I go to My Profile, or even when I enter http://mysite in the browser, I still get redirected to http://ourintranet/my

We have the exact same setup in our test environment (with http://mysitedev and http://ourintranetdev) where it's working perfectly. No IIS resets or any other restarts have been done.

Is there anything that we are missing?

share|improve this question
What is the location of your "Public Site Redirect" on your Profile? – Matthew McDermott May 10 '12 at 10:42
had a similar issue - I deleted all cookies in the browser and it sorted it out – user41672 Apr 24 '15 at 7:40
up vote 4 down vote accepted

Verify that My Site settings in User Profile Service Application are set to point to this correct My Site location (My Site Settings --> Setup My Sites --> My Site Host).

Verify that you don't have multiple WFE's in production that would have conflicting settings in terms of IIS bindings.

Verify trusted My Site host location doesn't include the old host location. Details

share|improve this answer
Thanks Jussi. My Site location is set up correctly. We have 1 WFE only, so there aren't any conflicts here. – Modery May 9 '12 at 5:23
Added one more thing to check above. – Jussi Palo May 10 '12 at 7:42
It was the Trusted My Site host location! Thanks Jussi! – Modery May 10 '12 at 11:41

I'm having the similar issue after migrating from SP2010 to 2013. Check this post:

share|improve this answer
While this may theoretically answer the question, we prefer inclusion of the essential parts of the answer here, and to provide the link for reference. See answer for general guidelines. Thanks. [moderator] – SPDoctor Mar 14 '13 at 19:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.