SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed the following on my Sharepoint 2010 Dev environment and now I am unable to browse to any of the sites neither am I able to create a web application. Is there a way I can roll back to previous settings or uninstall the updates? The products and configuration wizard failed as well. (Service Pack 1 for MSF) (Service Pack 1 for SP 2010) (December 2011 CU for MSF) (December 2011 CU for SP 2010)

enter image description here

share|improve this question
What error did the Config Wizard fail with? That is where you'll need to troubleshoot. – Trevor Seward May 8 '12 at 19:13
Trevor's right, the error from the config wizard will help figure out the problem. Updates cannot be uninstalled either, which means your only rollback options are restoring a snapshot (if this is a VM) or rebuilding the farm and restoring from backups. – shufler May 8 '12 at 19:45
Also, try re-running psconfig again. I had to do it twice on my dev environment. The second time was successful. – sween_sp May 8 '12 at 19:54
Try rebooting the machine and re-run the psConfig as Sween suggests. – Marius Constantinescu - MVP May 8 '12 at 20:29
@sween_sp I tried rebooting and rerunning twice with no luck. – user7400 May 8 '12 at 20:34
up vote 0 down vote accepted

I have tried everything suggested on this post and a lot more odd options with no luck. I just took down my dev server and brought it back up and restored my site collection back up.

Of course, I did not have much data (in which case it would not be recommended at all) but atleast it fixed my problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.