Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am able to search trusted domain users in peoplepicker search box. But in central admin, when I am trying to add them as site collection admin (after finding them in people picker search), it is giving redline under the username and not allowing to add them as site collection admin.

share|improve this question
1  
Is your machine on a single domain? If not is your account on the same domain (this shouldnt matter if you can see the names anyway) If you click on the name does it give you any options to choose the user? What happens if you manually type in the domain and name as domainname\username? –  Cory May 7 '12 at 16:34
    
I think it is not single domain. manually typed domainname\username still I am getting redline error. But able to find user in picker. –  James123 May 7 '12 at 16:42
1  
It might be finding more than one account. Left click on the name and see if it gives you more than one result. We see this becuase we use both forms authentication and Kerberos. –  sween_sp May 7 '12 at 16:43
    
its wondering... it shows on left click and got one name.. added underline came and clicked ok and again redline is coming and not adding it. –  James123 May 7 '12 at 17:19
    
What if you try to make them a site collection administrator at the site collection level? When you try to add them in central administration are there two people in the site collection administrator box? –  Cory May 8 '12 at 3:40
add comment

4 Answers 4

One reason this happens is when you force IE9 (or newer) mode on the IE8-only SharePoint 2010, the people picker will give you all sorts of issues. If you changed that in the masterpage or forced it on IE try forcing IE8 mode in the F12 Developer Tools to perform your People Picker actions (both Browser & Document Mode).

share|improve this answer
add comment

Try To add a site collection administrator by using Windows PowerShell

Set-SPSite -Identity "<SiteCollection>" -SecondaryOwnerAlias "<User>"

http://sharepointrelated.com/2012/09/20/change-site-collection-administrators-for-all-site-collections/

share|improve this answer
add comment

This issue is quite common in extranet sites:

To resolve this - Under site Actions -> Site Settings -> Extranet Settings -> Manage extranet settings. Now add the people you want to have access to the site. These names will appear in the people picker so that you can classify them into groups.

share|improve this answer
add comment

Make sure your people picker settings in your web applications web.config match your central admin web.config.

share|improve this answer
    
both looks same... all are windows web applications only... –  James123 May 7 '12 at 17:20
    
Was my first guess too. Have you tried iisreset / a simple reboot? Is the environment patched with the latest updates? –  Jasper Oct 9 '12 at 13:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.