Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Salve! In my Sharepoint Server 2010 site, I have subsite with some webparts on it. There is only one web-part zone, and the page is a wiki page. However, I want web-part #1 to appear below web-part #2. Normally, one would do this by changing the "Web-part zone". However, my property fields are grayed out in edit mode, but I also see that "AllowZoneChange" is marked to true.

How can I enable the zone-index field? What caused the field to be disabled?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

It is disabled on Wiki pages, because its not really a web part zone, but a rich-text editor. However you can move the web parts by using Drag&Drop.

share|improve this answer
    
That is the answer! I don't suppose that can be done with Powershell... –  BGM May 7 '12 at 14:29
add comment

This doesnt happen with all web parts on this page? I was thinking that maybe the web part zone was configured to disallow moving the web part. Is there only one web part zone on the page? If there is only one web part zone then the options would be grayed out to change the zone, but should show for positioning. What type of page is it? (Wiki, page layout, blank web part zone)

share|improve this answer
    
Hi, Cory. I have three web-parts. Yes, there is only one zone. The page is a wiki page - the default home page of a blank site (if I remember correctly, it's been awhile). If it is the zone that is configured so, how do I change the setting? –  BGM May 6 '12 at 23:20
    
Oh - yes, it happens with every web-part. –  BGM May 6 '12 at 23:59
    
You would have to open the page in SharePoint Designer. OOTB though you shouldnt need to worry about this. Once open in SharePoint Designer you would right click on the zone to get the options. One of those should be around what is allowed within the webpart zone. Depending on how the farm is configured though you may not be able to open the site. –  Cory May 7 '12 at 0:45
    
I checked all three web-parts in the zone, and they all are enabled for both edit and zone change. I don't see anything anywhere else besides that for configuring another edit mode. –  BGM May 7 '12 at 1:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.