Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

A while ago we engaged a consultant, who essentially re-built our SharePoint based website. Initially we had the standard ootb setup, i.e. the single sitecollection was on port 80 and visitors went directly to it. The consultant reconfigured it so that the 'base' web app was on port 100 using the local hostname (with NTLM access for easier searching), and then extended the site on port 80 (with our fully qualified domain and FBA) that the visitors would go to.

Last week I provisioned Web Analytics service application within Central Admin. I also did this at the same time on my dev server (which is the ootb style web app). A week later and Web Analytics reports still show no data, so I'm wondering if because people are visiting the extended site, not the 'base' site, Web Analytics isn't gather said data?

When I check Central Admin > Application Management > Service Applications > Configure service application associations, I only see the 'base' site listed (on port 100). This is why I'm wondering about the extended site not being analyzed.

Any ideas?

Kevin

share|improve this question
add comment

2 Answers 2

I had very similar scenario. Called Microsoft and all we did was make sure that on all of the SharePoint Servers (application, wfe, etc.) the "SharePoint Tracing" Windows service was running as Local System.

After a day we started seeing data on the report. If you need more details reply and I will walk you through these steps.

share|improve this answer
1  
Thanks for the feedback, and apologies for the delay in getting back to you (vacation). I checked the "SharePoint 2010 Tracing" service, and it's already Started, automatically, as Local Service, so I think our causes are different. Unless there's more to what you checked than just the service? –  QMKevin Jun 25 '12 at 12:41
add comment

So the default web application is running on the :100 host header. Is the web application currently connected to the Web Analytics under service connections?

share|improve this answer
    
The web application on port 100 is associated yes, as I mentioned in my original question. The extended site (on port 443) is not listed, and there seems to be no way to add it. –  QMKevin May 5 '12 at 14:42
    
You don't need to add the extended site. You just need to point to the internal site which is hosted on :100. It is a best practices to configure service applications to use internal zones that use Windows Authentication to successfully connect to the application. There are many instances, such as my environment, where services cannot connection to the application over 442 due to multi-factor authentication methods that are enforced. –  SPS Guy May 7 '12 at 15:10
    
OK, then there must be another cause of this. When I look at the Service Application Associations list I see http://myserver:100 listed under Web Application / Service Application, and that the Application Proxy Group is default and under the list of Application Proxies I see Web Analytics Service Application 1. I also know that the `Web Analytics Service Application and it's Proxy are both started. What else could this be? Do I have to publish the service application? Thanks for the help so far - much appreciated. –  QMKevin May 7 '12 at 15:37
    
If you are using the SA with 1 farm you do not need to publish it. If you plan to us it for multiple farms you need to publish it. Verify your config by following this: technet.microsoft.com/en-us/library/gg266382.aspx#section2 –  SPS Guy May 7 '12 at 19:18
    
As far as I can tell, I setup Web Analytics correctly, according to the link you provided (which I'd used before). I'm wondering if there is a way to look (and only look) at the databases to see if any content is being gathered? Setting up Web Analytics, I specified WAStaging and WAReporting as my database names. I didn't see any specific guidance on that, so I figured I could just make them up? (those are what I called them on the working DEV server). –  QMKevin May 8 '12 at 15:07
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.