Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

SharePoint search was working in my system last week, but in the weekend I noticed that it is not working.

I added some new documents to shared docs. But I cannot search inside them.

The crawl log was showing nothing.

The site is present in start address. I reset the search index did a full crawl,, restarted the search services, restarted system. The content access account is present in user profile service, it is also present in the user policy of the website. I am only able to search by title and enterprise keywords not the content inside document. I ran the products config wizard, I also reintstalled shareoint.All of no use. However today, I am able to crawl ppt,xls,doc,xlsx,txt but not docx, pptx.

The crawl log for these two items show...

Crawled ( The filtering process could not load the item. This is possibly caused by an unrecognized item format or item corruption. 0x40d30 )

any idea ?

Not yet checked for pdf.

share|improve this question
    
What version of SharePoint are you running on? –  John Chapman May 2 '12 at 17:05
add comment

2 Answers 2

Did you by any chance do an upgrade recently, and forget to run configuration wizard? This will render the SharePoint binaries out of sync with the database schema version. The crawler checks this, and refuses to index, but it only post this as (if I remember correctly) a "High" event in ULS log, so you might have missed it.

share|improve this answer
add comment

You may need to install the IFilters for Office 2007 documents: http://technet.microsoft.com/en-us/library/dd695738(v=office.12).aspx

Also, PDF files require you to install an IFilter for them too: http://www.adobe.com/support/downloads/detail.jsp?ftpID=4025

share|improve this answer
    
IFilters are what Windows (and ultimately SharePoint) use to process files for indexing. –  John Chapman May 2 '12 at 17:16
    
Thanks for the reply. I am working on sharepoint 2010 enterprise edition. I think the link you said is valid for sharepoint 2007. I can't understand how only docx and pptx are not working and got corrupt. do i still need to install the office filter as given in your comment as it is for sharepoint 2007 ? Pls help as I have spent 3 days for this and I cannot bear it... I have installed 64bit version of this microsoft.com/en-us/download/details.aspx?id=17062 but it doesn't work –  user8168 May 3 '12 at 3:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.