Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Scenario is this - site collection contains a sub-site with unique permissions. In that sub-site, site owner with full control creates link list. That list is not created with the same permissions as the sub-site (appears to have same permissions as site collection root site).

Sub-site owner has read permissions at root site level and consequently cannot add items to newly created link list. Sub-site owner goes to link list permissions and clicks inherit permissions.

Sharepoint gives unexpected error. Entire site collection now locking out all users with 500 internal server error. Central admin unable to do anything with site collection. PowerShell commands do not work on site collection.

Only way to do anything with the site collection was to restore from backup. Restored DB had additional row in the Perms table - suggests the inherit permissions operation may have deleted a row (could explain site collection lockout?).

AFAIK Sharepoint Server and Sql server are fine (space / permissions). Other site collections are operating fine.

Other than not to touch the inherit permissions button, can anyone shed any light on the issue? The issue is repeatable (in different site collections). Site underwent a SP 2007 > 2010 in place migration.

share|improve this question
    
This sounds crazy... Have you validated this yourself? I don't understand how the list in the sub-site would not automatically inherit the permissions of its parent (the sub-site). If it is reproducible, have you considered opening a ticket with Microsoft? –  Kit Menke May 1 '12 at 21:55
    
I've definitely validated this myself... I spent a not very enjoyable couple of hours last week recovering the site collection in question from backup (as any SP admin knows, that's 50% of the time researching the problem, 5% of the time restoring the site collection and the remaining 45% of the time explaining to management what went wrong...). I think you are right though - the key is the list in the sub-site not inheriting in the first place - when it is created and hasn't inherited, the problem already exists - subsequently trying to inherit permissions just brings it to light. –  fudoki22 May 2 '12 at 13:07
    
An update - we've now been able to track the problem to breaking the inheritance using Powershell. In case anyone wants to try and reproduce the steps are as follows:- 1) create vanilla sp farm. 2) add new site collection. 3) add subsite to new site collection. 4) run ps commands $web = get-spweb yoursite/subsite, $web.BreakRoleInheritance("true","true"). 5) check subsite has unique permissions. 6) create a list in subsite. 7) check list has unique permissions. 8) click inherit permissions for that list. 9) navigate to subsite and prepare to restore from backup. Going to refer to MS –  fudoki22 May 11 '12 at 17:29
    
A further update - a technician from Microsoft has been able to replicate the problem on his/her environment and is "working with us to resolve the issue". I'm not sure if this makes it an official bug, or if I should close the question as the solution seems to reside with MS. –  fudoki22 May 16 '12 at 12:59
    
Did your problem got resolved? I am also stuck with the same issue. –  Sankalp Jun 24 '12 at 15:25
add comment

1 Answer 1

First of all, thank you for the consise write-up of the problem. We encountered the exact same scenario yesterday on our site, and this post was the first glimmer of hope. Found another thread on the same topic, where a work-around solution was provided for the problem.

Link: http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/2a3525e1-5852-41e1-8815-7e772d23b306/

Solution by Ilya Lehrman (from link above):

Incidentally, if you find yourself in a situation where you're encountering the environment described here but BEFORE you click on inherit permissions in the list and blow everything up, here's the fix to, uh, fix the problem on the afflicted webs:

  1. Go up to the web's Permissions area
  2. Click on Inherit Permissions to remove unique permissions from the web
  3. Click on Stop Inheriting Permissions to re-break role inheritance (if you do it via UI, the bug does not appear)
  4. Set groups/users as you need them

you may choose to verify, between step 2 and 3, that your lists that used to have unique permissions (as part of the symptom of the problem) now have inherited permissions. After doing this, the problem goes away and you can safely create new lists.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.