Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a bunch of publishing sites upgraded from SharePoint 2007 to 2010 and our users have noticed an interesting difference. Not sure if it's related to our environment or a bug in 2010.

Basically when antoher user has the page checked out, in SharePoint 2007 the "Edit Page" option on Site Actions was disabled (greyed out). Our upgraded sites, running in V3 mode, so not yet run through the visual upgrade DON'T disable this button.

Once a user clicks on it, they are presented with an ASP.NET error page stating that:

This item must be checked out before its properties can be edited

The Edit Page link in 2007 production is disabled.

If anyone has come across this before and/or knows what a fix is, please let me know.

Regards,

Mark Stokes

share|improve this question
    
Are you using a SP2010 masterpage or are you using the SP2007 masterpage on the SP2010 site? –  Daniel Ziga Apr 30 '12 at 14:18
    
The site has not yet gone through Visual Upgrade, so it is using the 2007 Master Page. –  Mark Stokes Apr 30 '12 at 14:21
add comment

1 Answer 1

My issue was as per this post: "I was editing the page under 2 different accounts".

When I accessed the page as the SharePoint install account, I was able to edit the page (as this was the user I used to edit the page).

Obviously this shouldn't cause this bug, but it must be related to a SharePoint 2010 upgrade and staying in the old visual styles.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.