Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I try to connect a list (Tasks, Calendar) to Outlook via 'Action' -> 'Connect to Outlook' the connection is created. Outlooks asks to add the list, but the synchronization fails with:

Task ‘listName’ reported error (0×8000FFFF) : ‘An error occurred either in Outlook or SharePoint. Contact the SharePoint site administrator. HTTP 0.

What could be wrong, and how do I fix it?

Tech Details:
WSS (12.0.0.6421) on a SBS 2008 connecting with Outlook 2007 connecting via a https connection over the internet.
Internet url: https://vpn.sername.nl:987/
Default url: http://servername/

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

I found the problem.

The server was using a self-signed certificate on a local domain (company.local) When connecting over the internet to that machine the browser (and outlook) trys to verify if the certificate was revoked. This fails because the domain of the certificate is invalid for use of the internet. IE handles this correctly but Outlook doesn't (same for other office applications)

Quick solution: Disable certificate checking in your internet settings (Internet settings -> advanced -> Check if certificate was revoked ) BUT: this is a security risk, since it is a global setting, e.g. your OnlineBank transactions may not be secure anymore!

Good solution: fix the certificate and/or buy a 'real' one.

share|improve this answer
add comment

What authentication do you have?

Also this may be an issue with using high port numbers over the internet. Can you connect in the server when in the office?

share|improve this answer
    
We are using Windows Authentication, Integrated (using Kerberos). I can connect from 'The Office', There* the outlook integration is working fine. The list is connected via: ServerName/Lists/Tasks * on the server, there is no physical office –  Dribbel Oct 8 '09 at 8:36
    
Can you try extending the web application and using non-high ports. i.e. vpn.mycompany.nl and then add this url as a trusted site (so it passes credentials). –  AndrewWoody Oct 9 '09 at 10:44
add comment

This error is reported if you are not connected to the VPN. Where you able to access SharePoint, when this error was occuring?

share|improve this answer
    
There is no VPN connection, the server is accessible over the internet, since most users are 'on the road', using a https connection, defined in the AAM: vpn.servername.nl:987 as Extranet –  Dribbel Oct 8 '09 at 8:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.