Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I recently installed a Sharepoint 2010 solution about 3 months ago. The default URL http://companyweb was working nicely without issues.

Recently, however it just stopped working and now only browsing to the server name works.

I did notice that a couple of other issues had cropped up in the Sharepoint error log, like using accounts with high privileges being used for timer service. This is yet to be properly addressed however the service has since been restarted. I don't think this would be related to the AAM.

Are there any settings in IIS 7 that I can check? Where do I start to debug AAM problems?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

I think there can be several sources of the problem, if you URL stops working

  • something is wrong with your DNS server
  • someone changed IIS bindings
  • someone changed mappings in Central Administration

About the IIS settings, look into Bindings of your website. Right-click on website and choose Edit bindings.
Also go to Central Administration > Application Management > Configure alternate access mappings to check if something can be wrong there.

share|improve this answer
    
Points 2 and 3 have not changed which leaves us with the DNS server. What things should I be checking on the DNS? –  Seth Apr 26 '12 at 10:14
    
Start by doing a ping http://companyweb and check if it uses the IP address of the server. –  Per Jakobsen Apr 26 '12 at 17:45
    
It resolves to the correct IP address only when I ping it on the machine that the sharepoint server is running on. If I ping companyweb on another machine it can't resolve it and if I ping the actual IP address of the SP server it can find that. –  Seth Apr 27 '12 at 7:22
add comment

In this case it was definitely a DNS related issue. I deleted the CNAME record for companyweb in the DNS and re-added it and everything started working again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.