Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

A year ago, I created our SharePoint site under a test name. I then added an AAM to extend it to our production name. Just a month ago, I added an SSL redirect in IIS which sends all http requests to https. Everything works great. Discovered last week that when a user creates a workflow, the URLs of the tasks is http (instead of https) and has the test name rather than the production name.

Anyone have any suggestions? Thanks much!

share|improve this question

2 Answers 2

up vote 2 down vote accepted

The behavior is normal as the AAM doesn't know about your redirect, therefore the Workflow engine is not able to populate the proper Url. You should either use a Reverse'Proxy (e.g. ForeFront TMG, ISA 2006 ) that could automatically change your HTTP to HTTPS or Extend the Web Application to use HTTPS too.

Besides you can make also enable the "Configure Cross-Firewall Access Zone" to specify which of the URLs should be considered for the external alerts, emails and mobile urls.

Hope it helps, C:\Marius

share|improve this answer
    
Thanks for your response! Months ago, I had extended the web application to use HTTPS and it is working. I did some further testing this morning with the URLs and discovered that the install/original URL of tempname.abc.com does not work at all (just prompts me repeatedly to login & then reports "401 Unauthorized". Which would be fine except that as you pointed out that's also where the Workflow is trying to go. Both of my http and https AAMs prodname.abc.com and prodname.abc.com work fine. How do I get the Workflow to redirect too? Thanks! –  user4747 Apr 24 '12 at 14:48
    
Usually that is created in your AAM under Edit Public URLS. You need to put a link the Internet URL and also use the new configuration settings for "Cross-Firewall Access Zone". Usually the Workflows get this automatically, e.g .Approval workflow uses it in the TaskProcess: Item URL (UAG) as the property. –  C. Marius - MVP Apr 24 '12 at 14:55
    
Thanks. I have both in place as you've suggested and the original URL still does not work. –  user4747 Apr 24 '12 at 17:57
    
I'm sorry, i got lost in the middle - so which configuration is now in place?? The IIS rewrite would NOT fix it, where as the Extended Web App will most likely do! –  C. Marius - MVP Apr 24 '12 at 18:36
    
Apologies for my confusion. Hopefully this will help clarify - I have setup 2 AAMs for tempname.abc.com - one is prodname.abc.com (Internet) and the other is prodname.abc.com (Extranet). I have Extended the original Web App of tempname.abc.com (which has http & https setup on it) to prodname.abc.com (only http as when I add https it stops working). Lastly I have an URL rewrite on prodname.abc.com to SSL. Do I also need to Extend tempname.abc.com to prodname.abc.com? Thank you! –  user4747 Apr 30 '12 at 13:18

Try setting the UpdateAlert in powershell. Here is a link on the explanation http://www.wssdemo.com/Lists/stsadm/DispForm.aspx?ID=189&ContentTypeId=0x01001F9A291A8D9053488BAC958E9E294593

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.