SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using the Outlook Social Connector to link Outlook 2010 and SharePoint 2010. I finally have updates working. But, changes to SharePoint profile pictures show up as URLs rather than as pictures.

OSC showing urls

I've followed the steps described here to configure synchronization from SharePoint to the Active Directory:

I can see the data in the AD. There are no editable options in the SharePoint or AD for what type of data -- the thumbnailPhoto attribute is a URL type. It appears as if Outlook is expecting something different.

I posted a comment on that blog. But a week later and the author hasn't responded or even approved the comment.

Suggestions? Thanks, Tim

share|improve this question
I logged in as a different end user, setting up the Outlook profile in the process. Pictures show up fine in it. So, it's something screwy with the users who were already set up. But what? Or more to the point, who cares, how can I fix those existing users? – Anonymous Jun 15 '10 at 18:55
up vote 0 down vote accepted


That's because the Author doesn't work there any more. :) You can see your reply on this post.

"Not sure what you mean by "What Type". I chose the out of the box Picture Field in the Profile Property Editor. (I did not add my own field if that's what you mean.) "

share|improve this answer
Hi Matthew, I'm not the "Marcin" in the comments. But I think our comments might be related. When you define the export sync in SharePoint, there's a disabled drop-down labeled Type. The value in it was URL. Given that what I'm seeing in Outlook is a URL rather than a picture, I am assuming that I need to change that type. But, it could just be coincidence. When I look at the attribute in the AD, I see the same sort of data as you showed in one of your screenshots. – Anonymous Jun 15 '10 at 16:11
I'm marking this as the answer because Matthew's blog was apparently right. It just seems to not work for existing users (in my case at least). YMMV – Anonymous Jun 18 '10 at 13:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.