Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've got issues with the SharePoint 2010 Ribbon. At first I thought it was exactly the same as this: SharePoint Ribbon Loading endlessly

Here is what works:

  • the page ribbon works flawlessly on top level sites and subsites
  • the library tab works in all document libraries
  • the documents tab works in all document libraries
  • the calendar tab works in all calendars
  • the events tab works in all calendards

At random, the first tab in any ribbon (events or documents) will stop working by either being not clickable or be constantly spinning.

Testing this out on the server and I will never have any issues. If I have issues on my machine, run over to the server..no issues. If I make an entry to my hosts file to direct my machine to the ip address of one of the WFE that is not experiencing issues. I will still have issues with my browser. (yeah, I'm shutting down IE and reopening)

When I'm having issues, I can duplicate this in any mode inside IE and also in FF. Sometimes, when I have issues....I can open up a tab in 'inprivate browsing' and not have issues. This leads me to believe that certain sessions will start encountering issues. Also keep in mind that this issue will occur at random for some people and not have issues elsewhere.

Also, this only occurs with sites that have host headers. Port 80.

I have some f5 load balancers in front of the farm, but I thought that the changing of the hosts file would rule them out.

I have a scheduled reboot of the servers for tonight.

My question is, how else am I supposed to try to troubleshoot this? fiddler?

Any errors that I need to look out for in the event log?

I have no errors, but I do have warnings like this: Object Cache: The super user account utilized by the cache is not configured. This can increase the number of cache misses, which causes the page requests to consume unneccesary system resources. To configure the account use the following command 'stsadm -o setproperty -propertyname portalsuperuseraccount -propertyvalue account -url webappurl'. The account should be any account that has Full Control access to the SharePoint databases but is not an application pool account. Additional Data: Current default super user account: SHAREPOINT\system

share|improve this question
    
Is this on a load balanced farm? –  Dave Wise Apr 23 '12 at 16:34
    
Dave- yes we have load balancers –  bitterac Apr 23 '12 at 17:09
add comment

2 Answers

up vote 1 down vote accepted

It looks like a typical session affinity related problem. I've encountered a similar problem with F5 used in to off-load SSL in a SharePoint 2007 farm which suddenly lost functionality across clicks.

We've enabled in the F5 session affinity so that user doesn't actually get transferred from one server to the other during the same session. Microsoft consultant actually recomanded not to use F5 with SSL-offloading. We ended up also using F5 only as Reverse-Proxy which also resolved other issues.

Hope it helps, C:\Marius

share|improve this answer
add comment

If you aren't using sticky sessions on your load balancer then what you may be seeing is a case where subsequent requests back to the server for certain items, like images or JS files might be hitting the other server(s) in the balancer. If the application pool on that server has shut down due to inactivity then those requests will be stalled and may fail entirely, depending on how long it takes the other server to spin up the app pool.

You can get around this by adjusting the timeout on the application pool and also by using a Warm-up script to make sure that your appools are always loaded and ready to go.

share|improve this answer
    
Ok, we are using cookie insert for session persistence. It looks like the page is being treated as one session and the ribbon for another session. Looks to me that I need to put this issue on f5 to troubleshoot. –  bitterac Apr 23 '12 at 18:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.