Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I've just successfully followed this tutorial:

http://msdn.microsoft.com/en-us/library/ff728096.aspx

Not the best tutorial, but it's all working nevertheless.

My question is, now that I've managed to create a custom list, is there any way of omitting the mandatory Title field? I can't seem to find this field's definition in any of the xml but it's there regardless and not really suiting to the type of list I've created.

Thanks a lot.

share|improve this question
add comment

3 Answers 3

Yes, actually the recomanded way is to Hide that field or to use the FromBaseType="TRUE" Required="FALSE" Hidden="TRUE"

Also if you inherited from other CT use RemoveFieldRef http://msdn.microsoft.com/en-us/library/aa543602.aspx

share|improve this answer
    
Thanks for your reply @C. Marius - I can't seem to find the Required or Hidden or in fact any attributes for the Title field, I can't seem to see the field at all. –  DeeMac Apr 23 '12 at 14:00
    
These are regular attributes of course, i would suggest to install CAML extensions for VS2010 - very instructive visualstudiogallery.msdn.microsoft.com/… –  C. Marius - MVP Apr 23 '12 at 14:03
add comment

The Title column is derived from default Item content type. You can enable managing of content types in list settings and delete the default content type and as well as make this column optional in the content type you created.

Alternatively, you can rename this Title column to any mandatory field you would want to add to the List.

share|improve this answer
add comment

I recently ran up against this problem, and had difficulty finding the solution. Here's what I did to resolve it:

  • Set the Inherits property on the ContentType to be FALSE. If you don't do this, it seems, you can't change anything about the base content type (in this case Item) that the custom content type inherits from.
  • In the FieldRefs section for the Content Type, use the <RemoveFieldRef/> tag to completely remove that Field from your content type. It should now not show in Content Type.

The out-of-the-box ID of the Title field on SharePoint is {fa564e0f-0c70-4ab9-b863-0177e6ddd247}. This is, apparently, practically impossible (and pointless) to change and so should be the same for you.

I realise you asked this question a long time ago, but hopefully this answer will help the next person that stumbles across it like I did and save them some time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.