Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

OK I have posted other questions about this but no answers were given so I deleted them and thought I would try one last time before calling it a day...

I am trying to install RBS for SharePoint Foundation 2010 but I am not getting any confirmation in the log file that is generated from the command:

msiexec /qn /lvx* rbs_install_log.txt /i RBS.msi TRUSTSERVERCERTIFICATE=true FILEGROUP=PRIMARY DBNAME="WSS_Content" DBINSTANCE="<server name>" FILESTREAMFILEGROUP=RBSFilestreamProvider FILESTREAMSTORENAME=FilestreamProvider_1

I don't see any new tables created in SQL Server.

I am at my wits end because I can't seem to find an answer anywhere on here or Google. Can anybody out there help me??

Thanks.

share|improve this question
add comment

2 Answers

I had the same issue, run the RBS_x64.msi directly (double click on it). It'll walk through a wizard and create everything you need.

HTH

share|improve this answer
add comment

Start Command Prompt using the Run as administrator option.

msiexec /qn /lvx* rbs_install_log.txt /i RBS.msi TRUSTSERVERCERTIFICATE=true
FILEGROUP=PRIMARY DBNAME="SP_Content" DBINSTANCE="SP2010-WFE1"
FILESTREAMFILEGROUP=RBSFilestreamProvider FILESTREAMSTORENAME=FilestreamProvider_1

to Confirm the installation of RBS,

  • open rbs_install_Log.txt, and then confirm that you see the following line within the last 20 lines of the end of the file: Product: SQL Server 2008 R2 Remote Blob Store -- Installation completed successfully.
  • In SQL Server Management Studio, refresh the view of the Object Explorer tree, and then verify that several tables exist in the target content database that have names that begin with the letters mssqlrbs.

then enable RBS for your content database via SP2010 Management Shell, enable RBS for the WSS_Content_Intranet_IT database by typing the following commands:

$cdb = Get-SPContentDatabase "SP_Content_DB"
$rbss = $cdb.RemoteBlobStorageSettings
$rbss.Installed()
$rbss.Enable()
$rbss.SetActiveProviderName($rbss.GetProviderNames()[0])
share|improve this answer
    
Thanks for this! It's helped a bit but still problems. My logfile has grown immensely in size, but that states that the installation is complete nor are there any tables starting with mssqlrbs. I have haven't tried the enabling RBS step yet. –  Mark Apr 26 '12 at 8:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.