Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to add list.svc to a project in VS 2010. Even though, the path http://server/site/_vti_bin/listdata.svc is accessible through internet browsers, when I attempt to add service to my project, I get the error message below.

I recently changed the authentication method of my site to Claim Based Authentication, would that cause this error?

There was an error downloading 'http://server/site/_vti_bin/listdata.svc'. The underlying connection was closed: An unexpected error occurred on a receive. Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. An existing connection was forcibly closed by the remote host Metadata contains a reference that cannot be resolved: 'http://server/site/_vti_bin/listdata.svc'. An error occurred while receiving the HTTP response to http://server/site/_vti_bin/listdata.svc. This could be due to the service endpoint binding not using the HTTP protocol. This could also be due to an HTTP request context being aborted by the server (possibly due to the service shutting down). See server logs for more details. The underlying connection was closed: An unexpected error occurred on a receive. Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. An existing connection was forcibly closed by the remote host If the service is defined in the current solution, try building the solution and adding the service reference again.

Update:

If I go to http://server/site/_vti_bin/listdata.svc in my machine, it works.

However, if I go to http://server/site/_vti_bin/listdata.svc on the server, it says on Fiddler that "An existing connection was forcibly closed by the remote host"

Could you help me with how to solve this issue? Thanks.

share|improve this question
    
Q: Did you tried to add the reference via WCF Service Reference? Any load balancers or proxy settings in your browser? –  C. Marius - MVP Apr 18 '12 at 9:43
    
yes I am trying to add it via Add Service Reference. No loadbalancer or proxy on my browser... –  AnarchistGeek Apr 18 '12 at 9:54
    
Ok, so you say it works in browser (same machine, same address), but doing same from VS, get the error? Try using Fiddler while you add reference from VS 2010, see if your call passes properly. Try adding that url to your secure zone (Intranet, by example) and make sure your settings in the IIS - for the Web Application you are using WINDOWS. –  C. Marius - MVP Apr 18 '12 at 10:18
    
I have updated the question, it works on my local browser, but it does not on the web browser in server. strange. In VS add, it still get same error stated in the question. Adding site to secure zone did not make difference.. –  AnarchistGeek Apr 18 '12 at 12:18
    
Does browing the site using the browser on the server work. If not then it's probably LoopbackCheck that bides you. –  Per Jakobsen Apr 18 '12 at 12:24
show 7 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.