Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I created a sharepoint designer worklow, it has custom activities.

  1. I deployed the custom activities.
  2. I deployed the web.config changes with authorized types
  3. I did iisreset
  4. I uploaded the wsp to test environment
  5. I added the workflow to the calendar and when a new item is created

when I go to the new event created, and click on worklows, its not even started, the firt task in the workflow is actually Log History = This workflow started

but nothing appears.

Any idea?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Did you try manually starting the workflow? And if its working, I believe your new item in calendar is created using the System Account. SPD workflow will not start automatically under System Account.

Try logging in as a different user and post a new item. It should start the workflow automatically.

share|improve this answer
    
how can I manually start a workflow that should start automatically on the item created? –  L.V. Sharepoint Architect Apr 18 '12 at 8:29
1  
There will be a workflow attached to the item. Once the item is created, select the item in the list and on the drop down, go for workflows and click on the workflow attached and allow it start. This should start the workflow manually. Also, make sure that in your SPD workflow "allow the workflow to start automatically" is checked and published. –  Deepu Nair Apr 18 '12 at 8:52
    
thats the problem, the workflow is not even there, when I click the workflow button the event item, and yes I added the workflow to the content type –  L.V. Sharepoint Architect Apr 18 '12 at 9:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.