Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

To collaborate on building forms for collecting data, we are uploading our .xsn form templates to a document library in a "Sharepoint Admins" site.

There are a couple of problems with this approach though:

  • Contributors must have higher privileges because the "xsn" file type is on the blacklist. This issue is dealt with here: http://support.microsoft.com/kb/2483447
  • Once the file is uploaded, clicking the drop-down list of options next to the uploaded XSN file, I choose "Edit in Microsoft Infopath". This results in an error:

This form cannot be opened because it requires the domain permission level and it currently has restricted permission. To fix this problem, open the form from the location it was published to.

Published location: file:///C:\Users\george.collins\Documents...

My working theory is that Infopath is trying to open the XSN in "filler" mode rather than "designer", because I can work around it by right-clicking the file link, download it, then right-click on my machine and choose "edit".

We want to be able to work on forms as a team, and keep track of who's working on which form (i.e. exclusive check-out) and maintain versions over time.

We may be doing this completely wrong. Grateful for any advice.

share|improve this question

5 Answers 5

up vote 1 down vote accepted

Are you able to map a drive to the document library, or add a Network Share so that you can still interact with those files as if you are on the desktop. You are right regarding it wanting to open in the filler instead of in design mode.

Actually I have a better option for you. Sync SharePoint Workspace up with that library, you can select design from the SharePoint Workspace interface.

share|improve this answer
    
Thanks, I didn't know you could map a site to a network drive. There seems to be another issue now when I try to open the .xsn in design mode from the mapped folder. "Infopath cannot open the following form: ...[path to form] The form definition (.xsf) file contains one or more errors that prevent the form from opening". I don't have Sharepoint Workspace at the moment but will investigate that option if I can find it. –  GC. Apr 18 '12 at 9:01

had a similar situation our side

created a document library, saved the xsn's to that library and used sharepoint workspace to sync to the doc lib.

then from within workspace, can then right click on the file and design.

from there can publish the form to wherever for the users to fill out

;)

share|improve this answer

If you save (or upload) the form to a SP library the template points to your local drive. To avoid this issue publish your form as a content type. Then add it to a library. Whenever you or someone in your group need to update it, go to library settings, click on the content type, advance and then edit tempalte. The template opens in InfoPath for editing. Once you are done with editing publish it back.

share|improve this answer

You need to publish an infopath forms (XSN file) to a document library. (or ctype)

share|improve this answer
    
The thing is we're not publishing these forms for users to fill in - we just want to store them somewhere while we work on them. If I publish the form to a document library, how can we check them out to edit the form? Will sharepoint keep track of versions? –  GC. Apr 17 '12 at 15:05

Please confirm that you have given "Read Only/View Only" rights on site to users who will be updating/approving the tasks.

share|improve this answer
    
Please add details regarding how to do what you propose to your answer :) –  Robert Lindgren Mar 18 at 13:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.