Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We want to disable the social feature functionality but still make available the My Profile pages which is part of My Site. We also want disable the personal My Sites (My Content).

Under Permissions for User Profile Service Application we set the three permissions as follows:

  • Use Personal Features (true)
  • Create Personal Site (false)
  • Use Social Features (false)

According to the documentation we should disable "Use Social Features". But if we do that, the "My Profile" link in the user drop down menu disappears as well, with the effect that no user can get to their profile page anymore.

So what is the correct approach to disable the social features without disabling access to the my profiles page.

Thanks

share|improve this question
add comment

2 Answers

Here are different approaches to hide the Social taging feature:

Approach 1: Open Master Page and encpuslate below control into div. Set style with attribute

display:none
<div style=”display:none”>
<SharePoint:DelegateControl ControlId="GlobalSiteLink3-mini" Scope="Farm" runat="server"/>
</div>

Publish this master page no “SocialRibbonControl” will display.

Approach 2: On the Central Administration Web site, in the System Settings section, click Manage farm features. In the list of features, in the Social Tags and Note Board Ribbon Controls row, do one of the following: Click Activate. ClickDeactivate, and then click Deactivate this feature.

Approach 3:

Enable-SPFeature -Identity “SocialRibbonControl”

Disable-SPFeature -Identity “SocialRibbonControl”

Approach 4:

Ø On the Central Administration Web site, in the Application Management section, click Manage service applications.

Ø In the list of service applications, click the User Profile Service Application link.

Ø On the Manage Profile Service: User Profile Service Application page, in the People section, click Manage User Permissions.

Ø In the Permissions for User Profile Service Application dialog box, type or select a user or group account, and then click Add. Do one of the following:

Ø To enable the permission, in the Permissions for box, select the Use Social Features check box, and then click OK.

Ø To disable the permission, in the Permissions for box, clear the Use Social Features check box, and then click OK.

Approach 5:

Using Sharepoint:SPSecurityTrimmedControl - This allows the conditional display of content depending on the user’s permission. The content can be any HTML code or other controls. This will hide the links for some users according to the specified permission level.

Social media links on master page are generated by “<SharePoint:DelegateControl ControlId=”GlobalSiteLink3-mini” Scope=”Farm” runat=”server”/>” tag. So all you have to do is to add this tag in a security trimmed control and give the control appropriate permissions for trimming the tags. This will hide the tag for people with ManagePermissions on the site.

Something like below :

<Sharepoint:SPSecurityTrimmedControl runat=”server” Permissions=”ManagePermissions”>

<SharePoint:DelegateControl ControlId=”GlobalSiteLink3-mini” Scope=”Farm” runat=”server”/>

</SharePoint:SPSecurityTrimmedControl>

Approach 6:

Using User Profile Service - You can also disable these links for some of the users by disabling the social media option for the group in the users profile service. Steps would be:

Ø Go to the user profiles and properties service application in central admin.

Ø Click Manage User Permissions.

Ø Uncheck Use social features for a user or group to make these buttons go away.

share|improve this answer
    
Thank but it doesn,t solve my problem. Approach 2,3,4 and 6 disables the "My Site" and "My Profile"-links in the "Welcome" DropD-own-Menü as well, which is exactly what a I want to avoid. –  Flash265 Apr 16 '12 at 13:15
add comment

It might be because you are using a custom master page for My Site. Can you make v4.master as the custom master page when the permission is disabled and check?

If that does not work, may be you can try adding the navigation item under global navigation or current navigation by adding a link to "person.aspx" page, after disabling the permission. For this you need to go to Site Settings -> Navigation (Under Look and Feel).

share|improve this answer
1  
Thank you, but I have the problem with v4.master not with a custom master page. –  Flash265 Apr 16 '12 at 13:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.