Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

How do I enable anonymous access for only subsites of publishing sites?

share|improve this question
    
Please share the knowledge for how you implemented this, It would really helpful for the finding the solutions for us. –  user13357 Dec 2 '12 at 21:47

1 Answer 1

Go to the Site Permissions site and select Anonymous Access.

Select the Entire Site option and anonymous access will be enabled.

After the anonymous access is enabled you will find it listed in the Permissions as Anonymous Users.

share|improve this answer
    
Hi Mansi, Thanks for reply. Actually i have created a bolg in my site as a subsite. When i go Site Settings->Site Permissions. There is no option for anonymous access. How to get this option. if i enable it from central administration for my site then anonymous access enables for entire site but i want to give anonymous access only to my blog. Waiting for your reply. Thanks –  Feroze Apr 10 '12 at 7:44
    
Hi Feroze it was my pleasure.You donot need to explicitly provide anonymous access to the blog. All the users of the sharepoint site will be able to access it. Just try it out. –  Mansi Desai Apr 10 '12 at 8:11
    
You have to enable anonymous access for the Web Application (zone) in Central Admininistration, this doesn't really enable anonymous access, but just enables you to go the site collections and enable anonymous access there –  Per Jakobsen Apr 10 '12 at 8:32
    
Thanks you all. I have enabled anonymous access from central administration. My blog still not accessing (wwwqa.nextdocs.com/en-us/blogs) but i noticed that if i visit blog posts it works check: (wwwqa.nextdocs.com/en-us/blogs/Lists/Posts/Post.aspx?ID=1) so whats wrong with default.aspx page. :( –  Feroze Apr 10 '12 at 10:49
    
Looks like you got it working? Both pages work for me. –  SpartanDonut Nov 7 '12 at 18:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.