Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

i was having this error and i still cant solve it. btw, SP2010 running on win2k8r2.

I enabled the Indexing Service and still unable to get it running.

i suspect some network account issue and I have no idea how to fix it

here are some logs for you to help me out...

SQL error log : Login failed for user 'NT AUTHORITY\NETWORK SERVICE'. Reason: Failed to open the explicitly specified database. [CLIENT: ]

Event Log: Application Server job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (-).

Reason: Cannot open database "Search_Service_Application_CrawlStoreDB____________c" requested by the login. The login failed. Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.

Technical Support Details: System.Data.SqlClient.SqlException: Cannot open database "Search_Service_Application_CrawlStoreDB_________________" requested by the login. The login failed. Login failed for user 'NT AUTHORITY\NETWORK SERVICE'. at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize() at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

DB Problem Suspect: this db is in SUSPECT MODE ???!! SQL Database 'Search_Service_Application_CrawlStoreDB____________' on SQL Server instance 'servername\SharePoint' not found. Additional error information from SQL Server is included below.

Cannot open database "Search_Service_Application_CrawlStoreDB__________" requested by the login. The login failed. Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.

share|improve this question
add comment

1 Answer

For account, that can't access to db, try set up security explicitly. Run SQL Server Management Studio, connect to your server instance, under security->logins find (or add) your account, which cann't access, click to User Mapping tab, select your db (Search_Service_Application_CrawlStoreDB__________I assume) and set appropriate rights in the bottom (accessadmin or owner).

share|improve this answer
    
i found 2 problems after toying around with the entire database and settings ... the Crawl db was down, and the user account that was used for crawling never had the access rights to access the site that I wanted to crawl.. –  Melvin Apr 12 '12 at 1:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.