Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We have an BCS issue on a Sharepoint Foundation multi-tenant farm.

Users are able to create external content types using SharePoint Designer 2010, but when they browse to the list of external data we see an error stating "Unable to display this Web Part"

In the ULS logs is see System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Office.SecureStoreService, Version=14.0.0.0

Anyone have an idea?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

It appears that when ECT is created using Secure Store Application ID SharePoint 2010 Foundation cannot use it, because Secure Store Service is only available in Server edition. And though I was able to create ECT I couldn't run it.

I have a blog post about creating ECT to access SQL Server database properly here:

Setting up External Content Type for SQL Server database using SQL Server authentication - SharePoint 2010 Foundation

share|improve this answer
    
Nice work Slava! I'm happy that you figured it out! –  Anonymous Jun 22 '10 at 19:51
    
Thanks Andrew! I'm glad it can help someone else too. –  Anonymous Jun 23 '10 at 12:22
add comment

What authentication method is being set when using SPD 2010 to create the External Content Types?

share|improve this answer
    
Welcome to SharePoint.SE! If you have a new question, please ask it by clicking the Ask Question button. See How do I ask questions here? for further help. –  Kit Menke Jul 26 '12 at 18:33
    
If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. –  John Chapman Oct 16 '12 at 17:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.